summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
commit9bba3eb336f8cf3cd662f7d72e13e97d7d9e5561 (patch)
tree0a3202facd79a73511866b0b03da3f4671882f44 /gnu/packages/patches
parent800fef714c12768d54507870798e1f7850be2f0b (diff)
gnu: qxlsx: Fix include directory.
* gnu/packages/qt.scm (qxlsx)[source]: Add patch. * gnu/packages/patches/qxlsx-fix-include-directory.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/qxlsx-fix-include-directory.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/qxlsx-fix-include-directory.patch b/gnu/packages/patches/qxlsx-fix-include-directory.patch
new file mode 100644
index 0000000000..a68ca0cc3b
--- /dev/null
+++ b/gnu/packages/patches/qxlsx-fix-include-directory.patch
@@ -0,0 +1,24 @@
+From 8c3e6633e3c901bc5a5cd477383421b0980dcd26 Mon Sep 17 00:00:00 2001
+From: Alexey Sokolov <sokolov@google.com>
+Date: Mon, 17 Apr 2023 23:43:59 +0100
+Subject: [PATCH] Fix #278
+
+There's no real reason to install the same headers twice, but at least
+now clients of the library can build again
+---
+ QXlsx/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/QXlsx/CMakeLists.txt b/QXlsx/CMakeLists.txt
+index 4fa7f7f1..074922a8 100644
+--- a/QXlsx/CMakeLists.txt
++++ b/QXlsx/CMakeLists.txt
+@@ -179,7 +179,7 @@ PRIVATE
+ ${QXLSX_HEADERPATH}
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/header>
+- $<INSTALL_INTERFACE:include/QXlsx>
++ $<INSTALL_INTERFACE:include/QXlsxQt${QT_VERSION_MAJOR}>
+ )
+
+ set_target_properties(QXlsx PROPERTIES