summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-09 23:04:13 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 23:04:13 +0200
commit9ef33dce949214d018774a4ff82f069b1a5e1f0f (patch)
tree232590cdca27fc7c0a047d1903db7dbd0a6b1f40 /gnu/packages/patches
parent5fcbbe37c08dbe913d62523695a19357a08e2701 (diff)
parent8fbd8c82455e6f1bbbe623965b2452f8f8a01242 (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/qemu-build-info-manual.patch49
-rw-r--r--gnu/packages/patches/qemu-fix-agent-paths.patch37
2 files changed, 23 insertions, 63 deletions
diff --git a/gnu/packages/patches/qemu-build-info-manual.patch b/gnu/packages/patches/qemu-build-info-manual.patch
index 945c48a0e2..ff28266aaa 100644
--- a/gnu/packages/patches/qemu-build-info-manual.patch
+++ b/gnu/packages/patches/qemu-build-info-manual.patch
@@ -8,53 +8,14 @@ manual. The Texinfo format allows for more structure and info readers
provide more advanced navigation capabilities compared to manpages
readers.
-* configure (infodir): Add an --infodir option, which allows
-configuring the directory under which the info manuals are installed.
* docs/meson.build (texi, info): New targets.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-diff --git a/configure b/configure
---- a/configure
-+++ b/configure
-@@ -951,6 +951,8 @@ for opt do
- static="yes"
- QEMU_PKG_CONFIG_FLAGS="--static $QEMU_PKG_CONFIG_FLAGS"
- ;;
-+ --infodir=*) infodir="$optarg"
-+ ;;
- --mandir=*) mandir="$optarg"
- ;;
- --bindir=*) bindir="$optarg"
-@@ -978,7 +980,7 @@ for opt do
- --host=*|--build=*|\
- --disable-dependency-tracking|\
- --sbindir=*|--sharedstatedir=*|\
-- --oldincludedir=*|--datarootdir=*|--infodir=*|\
-+ --oldincludedir=*|--datarootdir=*|\
- --htmldir=*|--dvidir=*|--pdfdir=*|--psdir=*)
- # These switches are silently ignored, for compatibility with
- # autoconf-generated configure scripts. This allows QEMU's
-@@ -1599,6 +1601,7 @@ else
- fi
- mandir="${mandir:-$prefix/share/man}"
- datadir="${datadir:-$prefix/share}"
-+infodir="${infodir:-$datadir/info}"
- docdir="${docdir:-$prefix/share/doc}"
- sysconfdir="${sysconfdir:-$prefix/etc}"
- local_statedir="${local_statedir:-$prefix/var}"
-@@ -1736,6 +1739,7 @@ Advanced options (experts only):
- --with-git-submodules=validate fail if git submodules are not up to date
- --with-git-submodules=ignore do not update or check git submodules (default if no .git dir)
- --static enable static build [$static]
-+ --infodir=PATH install info manual in PATH
- --mandir=PATH install man pages in PATH
- --datadir=PATH install firmware in PATH/$qemu_suffix
- --localedir=PATH install translation in PATH/$qemu_suffix
diff --git a/docs/meson.build b/docs/meson.build
--- a/docs/meson.build
+++ b/docs/meson.build
-@@ -104,4 +104,25 @@ if build_docs
+@@ -92,4 +92,25 @@ if build_docs
alias_target('sphinxdocs', sphinxdocs)
alias_target('html', sphinxdocs)
alias_target('man', sphinxmans)
@@ -83,7 +44,7 @@ diff --git a/docs/meson.build b/docs/meson.build
diff --git a/meson.build b/meson.build
--- a/meson.build
+++ b/meson.build
-@@ -35,6 +35,7 @@ endif
+@@ -37,6 +37,7 @@ endif
qemu_confdir = get_option('sysconfdir') / get_option('qemu_suffix')
qemu_datadir = get_option('datadir') / get_option('qemu_suffix')
qemu_docdir = get_option('docdir') / get_option('qemu_suffix')
@@ -91,11 +52,11 @@ diff --git a/meson.build b/meson.build
qemu_moddir = get_option('libdir') / get_option('qemu_suffix')
qemu_desktopdir = get_option('datadir') / 'applications'
-@@ -2433,6 +2434,7 @@ else
+@@ -3698,6 +3699,7 @@ else
summary_info += {'local state directory': 'queried at runtime'}
endif
- summary_info += {'Doc directory': get_option('docdir')}
-+summary_info += {'Info directory': get_option('infodir')}
+ summary_info += {'Doc directory': get_option('prefix') / get_option('docdir')}
++summary_info += {'Info directory': get_option('prefix') / get_option('infodir')}
summary_info += {'Build directory': meson.current_build_dir()}
summary_info += {'Source path': meson.current_source_dir()}
summary_info += {'GIT submodules': config_host['GIT_SUBMODULES']}
diff --git a/gnu/packages/patches/qemu-fix-agent-paths.patch b/gnu/packages/patches/qemu-fix-agent-paths.patch
index bae62fadbf..0c29890206 100644
--- a/gnu/packages/patches/qemu-fix-agent-paths.patch
+++ b/gnu/packages/patches/qemu-fix-agent-paths.patch
@@ -4,7 +4,6 @@ after the patch from the Nix package:
https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/virtualization/qemu/fix-qemu-ga.patch
diff --git a/qga/commands-posix.c b/qga/commands-posix.c
-index 75dbaab..b416b03 100644
--- a/qga/commands-posix.c
+++ b/qga/commands-posix.c
@@ -84,6 +84,7 @@ static void ga_wait_child(pid_t pid, int *status, Error **errp)
@@ -15,33 +14,33 @@ index 75dbaab..b416b03 100644
Error *local_err = NULL;
pid_t pid;
int status;
-@@ -91,10 +92,13 @@ void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
+@@ -101,10 +102,13 @@ void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
slog("guest-shutdown called, mode: %s", mode);
if (!has_mode || strcmp(mode, "powerdown") == 0) {
- shutdown_flag = "-P";
+ shutdown_flag = powerdown_flag;
+ command = "shutdown";
} else if (strcmp(mode, "halt") == 0) {
- shutdown_flag = "-H";
+ shutdown_flag = halt_flag;
+ command = "halt";
} else if (strcmp(mode, "reboot") == 0) {
- shutdown_flag = "-r";
+ shutdown_flag = reboot_flag;
+ command = "reboot";
} else {
error_setg(errp,
"mode is invalid (valid values are: halt|powerdown|reboot");
-@@ -109,6 +113,11 @@ void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
- reopen_fd_to_null(1);
- reopen_fd_to_null(2);
-
+@@ -123,6 +127,11 @@ void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
+ execl("/sbin/shutdown", "shutdown", shutdown_flag, "-g0", "-y",
+ "hypervisor initiated shutdown", (char *)NULL);
+ #else
+ /* try Guix’s shutdown/halt/reboot first */
+ char *path = g_strdup_printf("/run/current-system/profile/sbin/%s", command);
-+ execle(path, command, (char *)NULL, environ);
++ execl(path, command, (char *)NULL);
+ g_free(path);
+
- execle("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
- "hypervisor initiated shutdown", (char *)NULL, environ);
- _exit(EXIT_FAILURE);
-@@ -158,10 +167,12 @@ void qmp_guest_set_time(bool has_time, int64_t time_ns, Error **errp)
+ execl("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
+ "hypervisor initiated shutdown", (char *)NULL);
+ #endif
+@@ -159,10 +168,12 @@ void qmp_guest_set_time(bool has_time, int64_t time_ns, Error **errp)
Error *local_err = NULL;
struct timeval tv;
static const char hwclock_path[] = "/sbin/hwclock";
@@ -55,12 +54,12 @@ index 75dbaab..b416b03 100644
}
if (!hwclock_available) {
-@@ -207,6 +218,8 @@ void qmp_guest_set_time(bool has_time, int64_t time_ns, Error **errp)
+@@ -208,6 +219,8 @@ void qmp_guest_set_time(bool has_time, int64_t time_ns, Error **errp)
/* Use '/sbin/hwclock -w' to set RTC from the system time,
* or '/sbin/hwclock -s' to set the system time from RTC. */
-+ execle(hwclock_path_guix, "hwclock", has_time ? "-w" : "-s",
-+ NULL, environ);
- execle(hwclock_path, "hwclock", has_time ? "-w" : "-s",
- NULL, environ);
++ execl(hwclock_path_guix, "hwclock", has_time ? "-w" : "-s",
++ NULL);
+ execl(hwclock_path, "hwclock", has_time ? "-w" : "-s", NULL);
_exit(EXIT_FAILURE);
+ } else if (pid < 0) {