summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-21 23:52:47 +0200
committerMarius Bakke <marius@gnu.org>2022-07-21 23:52:47 +0200
commitabea091dbef2d44e6eb46bd2413bdf917e14d095 (patch)
tree28f6c61dbda0acb52678944b121b66a6f50a3709 /gnu/packages/patches
parent3b20467807c32aeac56bbbe22ffb8823f68e282b (diff)
parent3f171587bc6a47bb056f3e699e17e05f5832aea5 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/containerd-create-pid-file.patch31
-rw-r--r--gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch63
2 files changed, 31 insertions, 63 deletions
diff --git a/gnu/packages/patches/containerd-create-pid-file.patch b/gnu/packages/patches/containerd-create-pid-file.patch
new file mode 100644
index 0000000000..668ffcd9e9
--- /dev/null
+++ b/gnu/packages/patches/containerd-create-pid-file.patch
@@ -0,0 +1,31 @@
+Copyright © 2022 Oleg Pykhalov <go.wigust@gmail.com>
+
+Create a PID file after containerd is ready to serve requests.
+
+Fixes <https://issues.guix.gnu.org/38432>.
+
+--- a/cmd/containerd/command/notify_linux.go 1970-01-01 03:00:01.000000000 +0300
++++ b/cmd/containerd/command/notify_linux.go 2022-07-02 04:42:35.553753495 +0300
+@@ -22,15 +22,22 @@
+ sd "github.com/coreos/go-systemd/v22/daemon"
+
+ "github.com/containerd/containerd/log"
++
++ "os"
++ "strconv"
+ )
+
+ // notifyReady notifies systemd that the daemon is ready to serve requests
+ func notifyReady(ctx context.Context) error {
++ pidFile, _ := os.Create("/run/containerd/containerd.pid")
++ defer pidFile.Close()
++ pidFile.WriteString(strconv.FormatInt(int64(os.Getpid()), 10))
+ return sdNotify(ctx, sd.SdNotifyReady)
+ }
+
+ // notifyStopping notifies systemd that the daemon is about to be stopped
+ func notifyStopping(ctx context.Context) error {
++ os.Remove("/run/containerd/containerd.pid")
+ return sdNotify(ctx, sd.SdNotifyStopping)
+ }
+
diff --git a/gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch b/gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch
deleted file mode 100644
index 746610c095..0000000000
--- a/gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 678ffd97db2d63cf6856428bea65a93e069f812f Mon Sep 17 00:00:00 2001
-From: Even Rouault <even.rouault@spatialys.com>
-Date: Wed, 4 Sep 2019 16:11:37 +0200
-Subject: [PATCH 1/2] Adapt test script for PROJ 6.2 EPSG database (fixes #22)
-
----
- libgeotiff/test/testlistgeo | 8 +++++++-
- libgeotiff/test/testlistgeo_out.dist | 4 ++--
- 2 files changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/libgeotiff/test/testlistgeo b/libgeotiff/test/testlistgeo
-index 7fb4a2f..571f5d0 100755
---- a/test/testlistgeo
-+++ b/test/testlistgeo
-@@ -210,10 +210,15 @@ echo "Testing listgeo equidistant_cylindrical.tif" >> ${OUT}
- $EXE ${DATA_DIR}/equidistant_cylindrical.tif >>${OUT}
- echo "" >>${OUT}
-
-+# Normalize for results depending on the exact version of PROJ / EPSG database
-+sed "s/ETRS89-extended/ETRS89/g" < ${OUT} > ${OUT}.tmp
-+mv ${OUT}.tmp ${OUT}
-+
-+sed "s/ETRS89-extended/ETRS89/g" < ${TEST_CLI_DIR}/testlistgeo_out.dist > testlistgeo_out.dist.tmp
-
- # do 'diff' with distribution results
- echo "diff ${OUT} with testlistgeo_out.dist"
--diff -u ${OUT} ${TEST_CLI_DIR}/testlistgeo_out.dist
-+diff -u ${OUT} testlistgeo_out.dist.tmp
- if [ $? -ne 0 ] ; then
- echo ""
- echo "PROBLEMS HAVE OCCURRED"
-@@ -224,6 +229,7 @@ else
- echo "TEST OK"
- echo "test file ${OUT} removed"
- echo
-+ rm testlistgeo_out.dist.tmp
- /bin/rm -f ${OUT}
- exit 0
- fi
-diff --git a/libgeotiff/test/testlistgeo_out.dist b/libgeotiff/test/testlistgeo_out.dist
-index 68a948c..c157f00 100644
---- a/test/testlistgeo_out.dist
-+++ b/test/testlistgeo_out.dist
-@@ -1738,11 +1738,11 @@ Geotiff_Information:
- Keyed_Information:
- GTModelTypeGeoKey (Short,1): ModelTypeProjected
- GTRasterTypeGeoKey (Short,1): RasterPixelIsArea
-- ProjectedCSTypeGeoKey (Short,1): Code-3035 (ETRS89 / LAEA Europe)
-+ ProjectedCSTypeGeoKey (Short,1): Code-3035 (ETRS89-extended / LAEA Europe)
- End_Of_Keys.
- End_Of_Geotiff.
-
--PCS = 3035 (ETRS89 / LAEA Europe)
-+PCS = 3035 (ETRS89-extended / LAEA Europe)
- Projection = 19986 (Europe Equal Area 2001)
- Projection Method: CT_LambertAzimEqualArea
- ProjCenterLatGeoKey: 52.000000 ( 52d 0' 0.00"N)
-
-From 15af10648c4cb7b4c55cbe08caaf9884c1d156d9 Mon Sep 17 00:00:00 2001
-From: Even Rouault <even.rouault@spatialys.com>
-Date: Wed, 4 Sep 2019 19:13:11 +0200
-Subject: [PATCH 2/2] appveyor.yml: build vcpkg from source to fix issue with
- VS2015