summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-25 08:16:32 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-04 12:05:52 +0200
commitbc2de56572872eefdc2992b34cce69c77deb485a (patch)
treeb26dc710476e249c8c276360afe1e57e2e83a65e /gnu/packages/patches
parent3ee5460b6338246b0b1e97c77b3f4b676f8a92bc (diff)
gnu: ruby-anystyle-data: Don't write to installed gem.
* gnu/packages/patches/ruby-anystyle-data-immutable-install.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ruby.scm (ruby-anystyle-data)[patches]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ruby-anystyle-data-immutable-install.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/ruby-anystyle-data-immutable-install.patch b/gnu/packages/patches/ruby-anystyle-data-immutable-install.patch
new file mode 100644
index 0000000000..d5d7149a67
--- /dev/null
+++ b/gnu/packages/patches/ruby-anystyle-data-immutable-install.patch
@@ -0,0 +1,40 @@
+From a6f5b37cd22daa6069d8fbef8cba9dc60a6731f6 Mon Sep 17 00:00:00 2001
+From: Philip McGrath <philip@philipmcgrath.com>
+Date: Sun, 24 Jul 2022 23:54:19 -0400
+Subject: [PATCH] `AnyStyle::Data.setup()`: adjust for immutable install
+
+Don't override the default paths for `Dictionary::Marshal`,
+`Dictionary::GDBM`, and `Dictionary:LDBM` to point to this gem: we can't
+populate such files without the 'anystyle' gem (which depends on this
+one), and we won't be able to write to the directory where this gem is
+installed later, so the files will never exist at those locations.
+---
+ lib/anystyle/data/setup.rb | 12 ------------
+ 1 file changed, 12 deletions(-)
+
+diff --git a/lib/anystyle/data/setup.rb b/lib/anystyle/data/setup.rb
+index 17efdf8..08246fa 100644
+--- a/lib/anystyle/data/setup.rb
++++ b/lib/anystyle/data/setup.rb
+@@ -4,18 +4,6 @@ module AnyStyle
+
+ def self.setup
+ Dictionary.defaults[:source] = File.join(ROOT, 'dict.txt.gz')
+-
+- if defined? Dictionary::Marshal
+- Dictionary::Marshal.defaults[:path] = File.join(ROOT, 'dict.marshal')
+- end
+-
+- if defined? Dictionary::GDBM
+- Dictionary::GDBM.defaults[:path] = File.join(ROOT, 'dict.db')
+- end
+-
+- if defined? Dictionary::LDBM
+- Dictionary::LDBM.defaults[:path] = ROOT
+- end
+ end
+ end
+ end
+--
+2.32.0
+