summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-20 09:06:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-20 10:08:54 +0300
commitbf8b03667fa361bc03ab44fcbc66e99c812c0c68 (patch)
tree6c3df544c8919460b43339033838a5478aed3879 /gnu/packages/patches
parent270eb27b20b4d1e024553a017f479556ee0b8ded (diff)
gnu: mrustc: Update to 0.10.0-2.597593a.
* gnu/packages/rust.scm (mrustc): Update to 0.10.0-2.597593a. [source]: Remove patch. (rust-bootstrap)[arguments]: Adjust custom 'patch-makefiles phase for changes in source. * gnu/packages/patches/mrustc-riscv64-support.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mrustc-riscv64-support.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/gnu/packages/patches/mrustc-riscv64-support.patch b/gnu/packages/patches/mrustc-riscv64-support.patch
deleted file mode 100644
index 6312116585..0000000000
--- a/gnu/packages/patches/mrustc-riscv64-support.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Patch sent upstream for review:
-https://github.com/thepowersgang/mrustc/pull/276
-
-diff --git a/src/trans/target.cpp b/src/trans/target.cpp
-index 420a2870..4d5eefb3 100644
---- a/src/trans/target.cpp
-+++ b/src/trans/target.cpp
-@@ -65,6 +65,13 @@ const TargetArch ARCH_POWERPC64LE = {
- { /*atomic(u8)=*/true, true, true, true, true },
- TargetArch::Alignments(2, 4, 8, 16, 4, 8, 8)
- };
-+// This is a guess
-+const TargetArch ARCH_RISCV64 = {
-+ "riscv64",
-+ 64, false,
-+ { /*atomic(u8)=*/true, true, true, true, true },
-+ TargetArch::Alignments(2, 4, 8, 16, 4, 8, 8)
-+};
- TargetSpec g_target;
-
-
-@@ -455,6 +462,13 @@ namespace
- ARCH_POWERPC64LE
- };
- }
-+ else if(target_name == "riscv64-unknown-linux-gnu")
-+ {
-+ return TargetSpec {
-+ "unix", "linux", "gnu", {CodegenMode::Gnu11, false, "riscv64-unknown-linux-gnu", BACKEND_C_OPTS_GNU},
-+ ARCH_RISCV64
-+ };
-+ }
- else if(target_name == "i586-pc-windows-gnu")
- {
- return TargetSpec {
-diff --git a/tools/common/target_detect.h b/tools/common/target_detect.h
-index a052da6b..42fea91a 100644
---- a/tools/common/target_detect.h
-+++ b/tools/common/target_detect.h
-@@ -34,6 +34,8 @@
- # define DEFAULT_TARGET_NAME "powerpc64-unknown-linux-gnu"
- # elif defined(__powerpc64__) && defined(__LITTLE_ENDIAN__)
- # define DEFAULT_TARGET_NAME "powerpc64le-unknown-linux-gnu"
-+# elif defined(__riscv) && __riscv_xlen == 64
-+# define DEFAULT_TARGET_NAME "riscv64-unknown-linux-gnu"
- # else
- # warning "Unable to detect a suitable default target (linux-gnu)"
- # endif