summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-13 00:59:31 +0200
committerMarius Bakke <marius@gnu.org>2022-09-13 14:53:08 +0200
commitc463d7ac916d86c4afd50dc5aecf645ff2deeb14 (patch)
tree62d359aa78fcb2c9ee903644c57a19fb611a3698 /gnu/packages/patches
parent389b5b5359e82be5e0417fd3505661b1800fca40 (diff)
gnu: OpenJDK@10: Fix build with newer toolchains.
* gnu/packages/java.scm (openjdk10)[source](patches): Add two patches. [source](snippet): While here, simplify. * gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch, gnu/packages/patches/openjdk-10-hotspot-stack-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch15
-rw-r--r--gnu/packages/patches/openjdk-10-hotspot-stack-size.patch28
2 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch b/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch
new file mode 100644
index 0000000000..2c64d06fbe
--- /dev/null
+++ b/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch
@@ -0,0 +1,15 @@
+Avoid ordered comparison of pointer with integer to prevent compile error
+with GCC 11.
+
+diff --git a/src/hotspot/os/linux/os_linux.cpp b/src/hotspot/os/linux/os_linux.cpp
+--- a/src/hotspot/os/linux/os_linux.cpp
++++ b/src/hotspot/os/linux/os_linux.cpp
+@@ -2155,7 +2155,7 @@ void os::Linux::print_container_info(outputStream* st) {
+ }
+
+ p = OSContainer::cpu_cpuset_memory_nodes();
+- if (p < 0)
++ if (p == NULL)
+ st->print("cpu_memory_nodes() failed\n");
+ else {
+ st->print("cpu_memory_nodes: %s\n", p);
diff --git a/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch b/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch
new file mode 100644
index 0000000000..2c246dbdbc
--- /dev/null
+++ b/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch
@@ -0,0 +1,28 @@
+Dynamically allocate the stack since SIGSTKSZ is not constant since glibc 2.34.
+
+Backported from:
+
+ https://github.com/openjdk/jdk17u/commit/bb7c412e259893091210267252faf3c0a1be0969
+
+diff --git a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
+--- a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
++++ b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
+@@ -67,8 +67,17 @@ static void handler(int sig, siginfo_t *si, void *unused) {
+ longjmp(context, 1);
+ }
+
++static char* altstack = NULL;
++
+ void set_signal_handler() {
+- static char altstack[SIGSTKSZ];
++ if (altstack == NULL) {
++ // Dynamically allocated in case SIGSTKSZ is not constant
++ altstack = malloc(SIGSTKSZ);
++ if (altstack == NULL) {
++ fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
++ exit(7);
++ }
++ }
+
+ stack_t ss = {
+ .ss_size = SIGSTKSZ,