summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-16 18:19:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-16 18:21:50 +0200
commitc72c10053dfdf76a148725fc3ff6a67c4144b778 (patch)
treea11427a898081e0539f83668234724e1481e66e6 /gnu/packages/patches
parente865e0b959a91b72d4d9193110ee44e24e1929be (diff)
gnu: bind: Update to 9.14.2.
* gnu/packages/dns.scm (isc-bind): Update to 9.14.2. [source]: Remove patch. [arguments]: Run only fuzz tests. * gnu/packages/patches/bind-fix-unused-pk11-ecc-constants.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bind-fix-unused-pk11-ecc-constants.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/patches/bind-fix-unused-pk11-ecc-constants.patch b/gnu/packages/patches/bind-fix-unused-pk11-ecc-constants.patch
deleted file mode 100644
index ab7cc83684..0000000000
--- a/gnu/packages/patches/bind-fix-unused-pk11-ecc-constants.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Thu, 25 Apr 2019 04:36:52 +0200
-Subject: [PATCH] gnu: bind: Fix unused PKCS#11 ECC constants.
-
-Without this patch, the build fails:
-
- pkcs11-keygen.c: In function ‘main’:
- pkcs11-keygen.c:424:32: error: ‘pk11_ecc_prime256v1’ undeclared (first use in this function)
- public_template[4].pValue = pk11_ecc_prime256v1;
- ^
- pkcs11-keygen.c:424:32: note: each undeclared identifier is reported only once for each function it appears in
- pkcs11-keygen.c:428:32: error: ‘pk11_ecc_secp384r1’ undeclared (first use in this function)
- public_template[4].pValue = pk11_ecc_secp384r1;
- ^
- make[2]: *** [Makefile:217: pkcs11-keygen.o] Error 1
-
-Fix copied verbatim from upstream[0].
-
-[0]: https://gitlab.isc.org/isc-projects/bind9/issues/935
-
----
---- orig-bind-9.11.6/bin/pkcs11/pkcs11-keygen.c 2019-02-27 15:28:15.000000000 -0800
-+++ bind-9.11.6/bin/pkcs11/pkcs11-keygen.c 2019-03-11 09:20:50.955257469 -0700
-@@ -403,6 +403,10 @@
- public_template[RSA_PUBLIC_EXPONENT].ulValueLen = expsize;
- break;
- case key_ecc:
-+#if !defined(HAVE_PKCS11_ECDSA)
-+ fprintf(stderr, "prime256v1 and secp3841r1 is not supported\n");
-+ usage();
-+#else
- op_type = OP_EC;
- if (bits == 0)
- bits = 256;
-@@ -429,7 +433,7 @@
- public_template[4].ulValueLen =
- sizeof(pk11_ecc_secp384r1);
- }
--
-+#endif
- break;
- case key_ecx:
- #if !defined(CKM_EDDSA_KEY_PAIR_GEN)