summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-05 23:56:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-05 23:56:22 +0100
commitf4a5faa9dcadc698383e15743ac5f974ee0e3c8b (patch)
tree96124567d5604c496cf8d2848ffe348de0b701ac /gnu/packages/patches
parent16b89ecc1f2f1f9651d119518c0e752b01f0f07b (diff)
parentadde15186da7529b85097fdafffc2a13b0e60bdf (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mailutils-uninitialized-memory.patch87
-rw-r--r--gnu/packages/patches/meandmyshadow-define-paths-earlier.patch50
-rw-r--r--gnu/packages/patches/myrepos-CVE-2018-7032.patch69
-rw-r--r--gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch17
-rw-r--r--gnu/packages/patches/rust-mdbook-support-reproducible-builds-by-forcing-window.search.patch25
-rw-r--r--gnu/packages/patches/telegram-purple-adjust-test.patch14
-rw-r--r--gnu/packages/patches/xapian-revert-5489fb2f8.patch23
-rw-r--r--gnu/packages/patches/zathura-pdf-mupdf-link-to-jpeg-libraries.patch55
8 files changed, 106 insertions, 234 deletions
diff --git a/gnu/packages/patches/mailutils-uninitialized-memory.patch b/gnu/packages/patches/mailutils-uninitialized-memory.patch
deleted file mode 100644
index ef4daf94cb..0000000000
--- a/gnu/packages/patches/mailutils-uninitialized-memory.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-Without this patch, the MH test suite would fail when building with
-glibc 2.26, with 'ali' segfaulting like this:
-
- Core was generated by `/tmp/guix-build-mailutils-3.4.drv-0/mailutils-3.4/mh/.libs/ali -a ./Mail/mh_ali'.
- Program terminated with signal SIGSEGV, Segmentation fault.
- #0 0x00007f8eac263a14 in hash (
- name=0x72642e342e332d73 <error: Cannot access memory at address 0x72642e342e332d73>, hash_num=0) at assoc.c:102
- 102 for (i = 0; *name; name++)
- (gdb) bt
- #0 0x00007f8eac263a14 in hash (
- name=0x72642e342e332d73 <error: Cannot access memory at address 0x72642e342e332d73>, hash_num=0) at assoc.c:102
- #1 0x00007f8eac263e6b in assoc_find_slot (assoc=0xaa59e0,
- name=0x72642e342e332d73 <error: Cannot access memory at address 0x72642e342e332d73>, install=0x0, slot=0x7ffcddcbf2b8) at assoc.c:219
- #2 0x00007f8eac264124 in mu_assoc_lookup (assoc=0xaa59e0,
- name=0x72642e342e332d73 <error: Cannot access memory at address 0x72642e342e332d73>, dataptr=0x7ffcddcbf2e0) at assoc.c:308
- #3 0x00007f8eac29e8ac in mu_ident_deref (
- name=0x72642e342e332d73 <error: Cannot access memory at address 0x72642e342e332d73>) at ident.c:98
- #4 0x00007f8eac29f8a6 in mu_locus_point_deinit (pt=0xaa5718) at locus.c:48
- #5 0x00007f8eac29fa1b in mu_locus_range_deinit (lr=0xaa5718) at locus.c:99
- #6 0x00007f8eac29f9db in mu_locus_range_copy (dest=0xaa5718,
- src=0x622be0 <ali_yylloc>) at locus.c:89
- #7 0x0000000000408a2a in push_source (name=0xaa74bc "mh_aliases2", fail=1)
- at mh_alias_lex.l:170
-
-commit b330af9008e4c9168b379867b854f5900a539ad7
-Author: Sergey Poznyakoff <gray@gnu.org>
-Date: Sat Nov 18 10:15:48 2017 +0200
-
- Fix the use of uninitialized memory
-
- * mh/mh_alias_lex.l (push_source): Initialize locus range prior to copying
- to it.
- * libmailutils/cfg/parser.y (mu_cfg_tree_create_node): Likewise.
- * libmu_sieve/util.c: (mu_sieve_value_create): Likewise.
-
-diff --git a/libmailutils/cfg/parser.y b/libmailutils/cfg/parser.y
-index 4503c7781..3436b8d90 100644
---- a/libmailutils/cfg/parser.y
-+++ b/libmailutils/cfg/parser.y
-@@ -1134,10 +1134,9 @@ mu_cfg_tree_create_node (struct mu_cfg_tree *tree,
-
- np = mu_alloc (size);
- np->type = type;
-+ mu_locus_range_init (&np->locus);
- if (loc)
- mu_locus_range_copy (&np->locus, loc);
-- else
-- memset (&np->locus, 0, sizeof np->locus);
- p = (char*) (np + 1);
- np->tag = p;
- strcpy (p, tag);
-diff --git a/libmu_sieve/sieve-lex.l b/libmu_sieve/sieve-lex.l
-index fd145bfe1..f14e80194 100644
---- a/libmu_sieve/sieve-lex.l
-+++ b/libmu_sieve/sieve-lex.l
-@@ -190,6 +190,7 @@ push_source (const char *name)
- {
- ctx = mu_sieve_malloc (mu_sieve_machine, sizeof (*ctx));
- ctx->trk = trk;
-+ mu_locus_range_init (&ctx->incl_range);
- mu_locus_range_copy (&ctx->incl_range, &yylloc);
- ctx->i_node = sieve_source_inode;
- ctx->input = input_stream;
-diff --git a/libmu_sieve/util.c b/libmu_sieve/util.c
-index 8d62a60c2..7d71b5509 100644
---- a/libmu_sieve/util.c
-+++ b/libmu_sieve/util.c
-@@ -55,6 +55,7 @@ mu_sieve_value_create (mu_sieve_machine_t mach, mu_sieve_data_type type,
- val->locus.end.mu_line = locus->end.mu_line;
- val->locus.end.mu_col = locus->end.mu_col;
-
-+ mu_locus_range_init (&val->locus);
- mu_locus_range_copy (&val->locus, locus);
- switch (type)
- {
-diff --git a/mh/mh_alias_lex.l b/mh/mh_alias_lex.l
-index 371353ed3..b97264b38 100644
---- a/mh/mh_alias_lex.l
-+++ b/mh/mh_alias_lex.l
-@@ -167,6 +167,7 @@ push_source (const char *name, int fail)
- {
- ctx = mu_alloc (sizeof (*ctx));
- ctx->trk = trk;
-+ mu_locus_range_init (&ctx->incl_range);
- mu_locus_range_copy (&ctx->incl_range, &yylloc);
- ctx->exec_p = exec_p;
- ctx->i_node = ali_source_inode;
diff --git a/gnu/packages/patches/meandmyshadow-define-paths-earlier.patch b/gnu/packages/patches/meandmyshadow-define-paths-earlier.patch
new file mode 100644
index 0000000000..505cbd23fe
--- /dev/null
+++ b/gnu/packages/patches/meandmyshadow-define-paths-earlier.patch
@@ -0,0 +1,50 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Wed, 31 Oct 2018 02:24:26 +0100
+Subject: [PATCH] gnu: meandmyshadow: Define paths earlier.
+
+The following patch was taken verbatim from the upstream repository[0]
+and will be included in the next release.
+
+[0]: https://github.com/acmepjz/meandmyshadow/pull/29
+---
+From 4847e6b5755258a1e0534f2d4b91dce2ce3b459e Mon Sep 17 00:00:00 2001
+From: Dmitry Marakasov <amdmi3@amdmi3.ru>
+Date: Wed, 24 Oct 2018 23:31:19 +0300
+Subject: [PATCH] Define paths earlier in CMakeLists.txt
+
+At the very least, paths should be defined before Configure_File(), otherwise empty DATAROOTDIR is substituted in config.h
+---
+ CMakeLists.txt | 13 +++++++------
+ 1 file changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e79639a..6321d9d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,6 +2,13 @@ Project (meandmyshadow)
+ CMake_Minimum_Required (VERSION 3.1)
+ Set (CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+
++#Path options
++Set (BINDIR "bin" CACHE STRING "Where to install binaries")
++Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
++Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
++Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
++
++#Options
+ Option (DEBUG_MODE "Compile the game with debug mode enabled" OFF)
+ Option (DISABLED_DEBUG_STUFF "Enable this you'll see a lot of annoying script debug messages which will lag the game." OFF)
+
+@@ -164,12 +171,6 @@ Target_Link_Libraries (
+ ${LUA_LIBRARIES}
+ )
+
+-#Path options
+-Set (BINDIR "bin" CACHE STRING "Where to install binaries")
+-Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
+-Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
+-Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
+-
+ #Install locations
+ Install (DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${DATAROOTDIR}/meandmyshadow/)
+ Install (FILES AUTHORS DESTINATION ${DATAROOTDIR}/meandmyshadow/)
diff --git a/gnu/packages/patches/myrepos-CVE-2018-7032.patch b/gnu/packages/patches/myrepos-CVE-2018-7032.patch
deleted file mode 100644
index ce9493e5f9..0000000000
--- a/gnu/packages/patches/myrepos-CVE-2018-7032.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-http://source.myrepos.branchable.com/?p=source.git;a=patch;h=40a3df21c73f1bb1b6915cc6fa503f50814664c8
-This can be removed with the next release. It was modified slightly to apply
-
-From 40a3df21c73f1bb1b6915cc6fa503f50814664c8 Mon Sep 17 00:00:00 2001
-From: Paul Wise <pabs3@bonedaddy.net>
-Date: Sun, 11 Feb 2018 21:57:49 +0800
-Subject: [PATCH] Mitigate vulnerabilities caused by some git remotes being
- able to execute code
-
-Set GIT_PROTOCOL_FROM_USER=0 with git versions newer than 2.12.
-
-Prevent remote websites from causing cloning of local repositories.
-
-Manually whitelist known-safe protocols (http, https, git, ssh)
-when using git versions older than 2.12.
-
-Fixes: CVE-2018-7032
-Fixes: https://bugs.debian.org/840014
-Suggestions-by: Jakub Wilk <jwilk@jwilk.net>
-Reported-by: Jakub Wilk <jwilk@jwilk.net>
----
- webcheckout | 22 +++++++++++++++++++++-
- 1 file changed, 21 insertions(+), 1 deletion(-)
-
-diff --git a/webcheckout b/webcheckout
-index e98da5c..de497ba 100755
---- a/webcheckout
-+++ b/webcheckout
-@@ -71,6 +71,16 @@ use Getopt::Long;
- use warnings;
- use strict;
-
-+# Mitigate some git remote types being dangerous
-+my $git_unsafe = 1;
-+my $git_version = `git --version`;
-+$git_version =~ s{^git version }{};
-+my ($major, $minor) = split(/\./, $git_version);
-+if (int($major) >= 2 && int($minor) >= 12) {
-+ $ENV{GIT_PROTOCOL_FROM_USER} = 0;
-+ $git_unsafe = 0;
-+}
-+
- # What to download.
- my $url;
-
-@@ -89,7 +99,17 @@ my $destdir;
-
- # how to perform checkouts
- my %handlers=(
-- git => sub { doit("git", "clone", shift, $destdir) },
-- svn => sub { doit("svn", "checkout", shift, $destdir) },
-- bzr => sub { doit("bzr", "branch", shift, $destdir) },
-+ git => sub {
-+ my $git_url = shift;
-+ # Reject unsafe URLs with older versions of git
-+ # that do not already check the URL safety.
-+ if ($git_unsafe && $git_url !~ m{^(?:(?:https?|git|ssh):[^:]|(?:[-_.A-Za-z0-9]+@)?[-_.A-Za-z0-9]+:(?!:|//))}) {
-+ print STDERR "potentially unsafe git URL, may fail, touch local files or execute arbitrary code\n";
-+ return 1;
-+ }
-+ # Reject cloning local directories too, webcheckout is for remote repos
-+ doit(qw(git -c protocol.file.allow=user clone --), $git_url, $destdir)
-+ },
-+ svn => sub { doit(qw(svn checkout --), shift, $destdir) },
-+ bzr => sub { doit(qw(bzr branch --), shift, $destdir) },
- );
---
-2.11.0
-
diff --git a/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch b/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
index 6ffc897297..a2bad55117 100644
--- a/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
+++ b/gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch
@@ -1,5 +1,6 @@
GDB responds with some overly detailed lines - which makes the tests fail.
Patch rust to accept those instead.
+See <https://github.com/rust-lang/rust/issues/54178>.
diff -ur orig/rustc-1.25.0-src/src/test/debuginfo/generic-enum-with-different-disr-sizes.rs rustc-1.25.0-src/src/test/debuginfo/generic-enum-with-different-disr-sizes.rs
--- orig/rustc-1.25.0-src/src/test/debuginfo/generic-enum-with-different-disr-sizes.rs 2018-09-13 10:24:33.775565159 +0200
+++ rustc-1.25.0-src/src/test/debuginfo/generic-enum-with-different-disr-sizes.rs 2018-09-13 10:25:56.322513658 +0200
@@ -92,3 +93,19 @@ diff -ur orig/rustc-1.25.0-src/src/test/debuginfo/generic-tuple-style-enum.rs ru
// gdb-command:print univariant
// gdbg-check:$4 = {{__0 = -1}}
+--- orig/rustc-1.25.0-src/src/test/debuginfo/nil-enum.rs 2018-09-13 10:24:33.783565071 +0200
++++ rustc-1.25.0-src/src/test/debuginfo/nil-enum.rs 2018-10-26 18:19:20.404564587 +0200
+@@ -17,11 +17,11 @@
+
+ // gdb-command:print first
+ // gdbg-check:$1 = {<No data fields>}
+-// gdbr-check:$1 = <error reading variable>
++// gdbr-check:$1 = nil_enum::ANilEnum
+
+ // gdb-command:print second
+ // gdbg-check:$2 = {<No data fields>}
+-// gdbr-check:$2 = <error reading variable>
++// gdbr-check:$2 = nil_enum::AnotherNilEnum
+
+ #![allow(unused_variables)]
+ #![feature(omit_gdb_pretty_printer_section)]
diff --git a/gnu/packages/patches/rust-mdbook-support-reproducible-builds-by-forcing-window.search.patch b/gnu/packages/patches/rust-mdbook-support-reproducible-builds-by-forcing-window.search.patch
new file mode 100644
index 0000000000..ef7bf53b5d
--- /dev/null
+++ b/gnu/packages/patches/rust-mdbook-support-reproducible-builds-by-forcing-window.search.patch
@@ -0,0 +1,25 @@
+From b9ca108fcae2b738ca3f0c88c84ae5dc5a6f843f Mon Sep 17 00:00:00 2001
+From: Tim Ryan <id@timryan.org>
+Date: Mon, 14 May 2018 06:22:21 -0400
+Subject: [PATCH] Support reproducible builds by forcing window.search to use
+ stable key ordering. (#692)
+See <https://github.com/rust-lang-nursery/mdBook/pull/692>
+---
+ src/vendor/mdbook/src/renderer/html_handlebars/search.rs | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/vendor/mdbook/src/renderer/html_handlebars/search.rs b/src/vendor/mdbook/src/renderer/html_handlebars/search.rs
+index d49772f8b..1ee66a511 100644
+--- a/src/vendor/mdbook/src/renderer/html_handlebars/search.rs
++++ b/src/vendor/mdbook/src/renderer/html_handlebars/search.rs
+@@ -205,6 +205,10 @@ fn write_to_js(index: Index, search_config: &Search) -> Result<String> {
+ searchoptions,
+ index,
+ };
++
++ // By converting to serde_json::Value as an intermediary, we use a
++ // BTreeMap internally and can force a stable ordering of map keys.
++ let json_contents = serde_json::to_value(&json_contents)?;
+ let json_contents = serde_json::to_string(&json_contents)?;
+
+ Ok(format!("window.search = {};", json_contents))
diff --git a/gnu/packages/patches/telegram-purple-adjust-test.patch b/gnu/packages/patches/telegram-purple-adjust-test.patch
new file mode 100644
index 0000000000..db3b497d5d
--- /dev/null
+++ b/gnu/packages/patches/telegram-purple-adjust-test.patch
@@ -0,0 +1,14 @@
+This test incorrectly expects the libpurple search path to initially
+contain exactly one element. Remove this incorrect assertion.
+
+--- telegram-purple-1.3.1-checkout/test/loadtest.c 2018-10-27 16:25:06.258459600 +0200
++++ telegram-purple-1.3.1-checkout/test/loadtest.c 2018-10-27 16:25:11.830434770 +0200
+@@ -156,7 +156,7 @@ static void tdf_inject_plugin (void) {
+ printf ("Injecting our module into purple_plugins_* ...\n");
+ purple_plugins_init ();
+ GList *search_paths = purple_plugins_get_search_paths ();
+- assert (!search_paths->prev && !search_paths->next && search_paths->data);
++ assert (!search_paths->prev && search_paths->data);
+ GList *new_paths = g_list_append (search_paths, g_strdup ("bin/"));
+ assert (new_paths == search_paths);
+ // Load "my" path before the default.
diff --git a/gnu/packages/patches/xapian-revert-5489fb2f8.patch b/gnu/packages/patches/xapian-revert-5489fb2f8.patch
deleted file mode 100644
index 7b78e2abb5..0000000000
--- a/gnu/packages/patches/xapian-revert-5489fb2f8.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Revert this upstream commit which breaks a test case in "notmuch":
-
-https://git.xapian.org/?p=xapian;a=commitdiff;h=5489fb2f838c0f0b0a593b4c17df282a93a1fe5a
-
-See the notmuch FAQ entry:
-
-https://notmuchmail.org/faq/#index12h2
-
-This should be fixed for later releases.
-
-diff --git a/backends/glass/glass_postlist.cc b/xapian-core/backends/glass/glass_postlist.cc
-index 80e578b85..a47f14a68 100644
---- a/backends/glass/glass_postlist.cc
-+++ b/backends/glass/glass_postlist.cc
-@@ -759,7 +759,7 @@ GlassPostList::open_nearby_postlist(const std::string & term_,
- (void)need_pos;
- if (term_.empty())
- RETURN(NULL);
-- if (!this_db.get() || this_db->postlist_table.is_modified())
-+ if (!this_db.get() || this_db->postlist_table.is_writable())
- RETURN(NULL);
- RETURN(new GlassPostList(this_db, term_, cursor->clone()));
- }
diff --git a/gnu/packages/patches/zathura-pdf-mupdf-link-to-jpeg-libraries.patch b/gnu/packages/patches/zathura-pdf-mupdf-link-to-jpeg-libraries.patch
deleted file mode 100644
index 63e058bbef..0000000000
--- a/gnu/packages/patches/zathura-pdf-mupdf-link-to-jpeg-libraries.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Mon, 18 Jun 2018 02:37:41 +0200
-Subject: zathura-pdf-mupdf: Link to JPEG libraries.
-
-As of version 0.3.3, zathura-pdf-mupdf no longer links to some required
-JPEG libraries, leading to such errors as:
-
- $ zathura foo.pdf
- error: Could not load plugin '/gnu/store/...-profile/lib/zathura/libpdf-mupdf.so' (/gnu/store/...-profile/lib/zathura/libpdf-mupdf.so: undefined symbol: jpeg_resync_to_restart).
-
-The patch below, copied verbatim from Arch[0], fixes that.
-Its description happens to match our reality, too.
-
-[0]: https://git.archlinux.org/svntogit/community.git/tree/trunk?h=packages/zathura-pdf-mupdf
----
-From 3fb0ff750373d45d4f5172ce1d41b74183cd07e8 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Johannes=20L=C3=B6thberg?= <johannes@kyriasis.com>
-Date: Sat, 24 Mar 2018 14:31:18 +0100
-Subject: [PATCH] Explicitly link against jbig2dec, openjp2, and jpeg
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Normally these are statically linked into libmupdfthird, but we delete
-those to make mupdf use the system libraries. Previously
-zathura-pdf-mupdf explicitly linked against them, but this is
-technically incorrect since they are supposed to be in libmupdfthird so
-that was removed. This commit essentially reverts that in the new build
-system.
-
-Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
----
- meson.build | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 3b0d7b7..ae2fc9c 100644
---- a/meson.build
-+++ b/meson.build
-@@ -22,7 +22,11 @@ cairo = dependency('cairo')
- mupdf = cc.find_library('mupdf')
- mupdfthird = cc.find_library('mupdfthird')
-
--build_dependencies = [zathura, girara, glib, cairo, mupdf, mupdfthird]
-+jbig2dec = cc.find_library('jbig2dec')
-+openjp2 = cc.find_library('openjp2')
-+jpeg = cc.find_library('jpeg')
-+
-+build_dependencies = [zathura, girara, glib, cairo, mupdf, mupdfthird, jbig2dec, openjp2, jpeg]
-
- # defines
- defines = [
---
-2.16.3
-