summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-06 10:07:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-06 10:07:36 +0200
commit378d94e51b00c30b19a39154278d01f1f3c4dbc1 (patch)
tree0c9ed3a1c1b6db778b05ad03fa8edd91cfb737f4 /gnu/packages/pcre.scm
parentd350d5e71434704d147b1252d21e46daf6bb9885 (diff)
parent6a5198170ed5f10e1eee2e25fc6a39f3f33a40fd (diff)
Merge remote-tracking branch 'origin/master' into wip-texlive
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 1395a3ea40..7385c78b9f 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -89,6 +89,7 @@ POSIX regular expression API.")
(define-public pcre2
(package
(name "pcre2")
+ (replacement pcre2/fixed)
(version "10.33")
(source (origin
(method url-fetch)
@@ -125,3 +126,14 @@ own native API, as well as a set of wrapper functions that correspond to the
POSIX regular expression API.")
(license license:bsd-3)
(home-page "https://www.pcre.org/")))
+
+(define-public pcre2/fixed
+ ;; PHP >= 7.3.8 requires a fixed version at build time, so make it public
+ ;; and hide it in the UI.
+ (package
+ (inherit pcre2)
+ (source
+ (origin
+ (inherit (package-source pcre2))
+ (patches (search-patches "pcre2-fix-jit_match-crash.patch"))))
+ (properties '((hidden? . #t)))))