summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2020-09-06 17:27:54 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-09-07 08:49:03 +0200
commit226bb93494377054614f0d212c2930aef4ff0cf0 (patch)
tree304ddaba600a0fc754b9c688cf8aea972406db62 /gnu/packages/pdf.scm
parentff4260d2babd594fce0d53d02fd961db0297e30a (diff)
gnu: xournalpp: Fix path to addr2line binary.
* gnu/packages/pdf.scm (xournalpp)[arguments]: Add phase substituting path of addr2line utility. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 7649bff695..4c11111323 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -848,6 +848,14 @@ using a stylus.")
(for-each (lambda (po) (chmod po #o666))
(find-files "." "\\.po$"))
#t))
+ ;; Fix path to addr2line utility, which the crash reporter uses.
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/util/Stacktrace.cpp"
+ ;; Match only the commandline.
+ (("\"addr2line ")
+ (string-append "\"" (which "addr2line") " ")))
+ #t))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs