summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 14:36:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:01 +0100
commitd8013ee221bd599474340899ffb5974796091955 (patch)
tree66eb4601e19660d1353511fdf715d1d2ae7ea02d /gnu/packages/pdf.scm
parentf210e94432fcb8d6c03589287833f7594f270522 (diff)
gnu: Remove needless inputs python-pip and python2-pip.
This is installed together with Python 3 anyway and for our build of Python 2. * gnu/packages/python.scm (python2-fixtures): [inputs] remove "python-pip". * gnu/packages/pdf.scm (python2-reportlab): [native-inputs] remove "python2-pip". (python-reportlab)[properties]: remove "python2-variant".
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 171f1990f7..e447ef1603 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -650,14 +650,10 @@ using a stylus.")
(description "This is the ReportLab PDF Toolkit. It allows rapid creation
of rich PDF documents, and also creation of charts in a variety of bitmap and
vector formats.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-reportlab))))))
+ (license license:bsd-3)))
(define-public python2-reportlab
- (package
- (inherit (package-with-python2
- (strip-python2-variant python-reportlab)))
- (native-inputs `(("python2-pip" ,python2-pip)))))
+ (package-with-python2 python-reportlab))
(define-public impressive
(package