summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
commit961d2ee2695b38503b463d055e9c7edbcc0bf307 (patch)
tree82d9b40477a1d4d88e75a187b2b637a56751480b /gnu/packages/perl-check.scm
parent7cf79d7a51ff5dde4fc430fab2296b5f7de08953 (diff)
parentaebba13c0bef5a58697f1a9fe8337967cc01300f (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 9944c31305..67bdfd81c4 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -66,9 +66,9 @@ implementation as used in cperl. It does not store the mocked overrides
lexically, just dynamically.")
(license artistic2.0)))
-(define-public perl-test2-bundle-extended
+(define-public perl-test2-suite
(package
- (name "perl-test2-bundle-extended")
+ (name "perl-test2-suite")
(version "0.000072")
(source
(origin
@@ -88,7 +88,7 @@ lexically, just dynamically.")
`(("perl-importer" ,perl-importer)
("perl-term-table" ,perl-term-table)
("perl-sub-info" ,perl-sub-info)))
- (home-page "https://metacpan.org/pod/Test2::Bundle::Extended")
+ (home-page "https://metacpan.org/pod/Test2-Suite")
(synopsis "Full set of tools for Test2::Suite")
(description "This package provides a rich set of tools, plugins, bundles,
etc built upon the Test2 testing library.")
@@ -107,8 +107,10 @@ etc built upon the Test2 testing library.")
(base32
"002qk6qsm0l6r2kaxywvc38w0yf0mlavgywq8li076pn6kcw3242"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-ipc-run3" ,perl-ipc-run3)))
(propagated-inputs
- `(("perl-test2-bundle-extended" ,perl-test2-bundle-extended)))
+ `(("perl-test2-suite" ,perl-test2-suite)))
(home-page "https://metacpan.org/release/Test2-Plugin-NoWarnings")
(synopsis "Fail if tests warn")
(description "Loading this plugin causes your tests to fail if there any
@@ -243,7 +245,6 @@ using @code{Test::Class}.")
("perl-test-requires" ,perl-test-requires)
("perl-test-deep" ,perl-test-deep)
("perl-test-warnings" ,perl-test-warnings)
- ("perl-test-tester" ,perl-test-tester)
("perl-test-needs" ,perl-test-needs)))
(propagated-inputs
`(("perl-namespace-clean" ,perl-namespace-clean)
@@ -349,8 +350,7 @@ specification.")
(base32
"1kdy06r0yg7zwarqglc9163vbfb0sfc4s6ld4pw5q7i9f7mghzi0"))))
(build-system perl-build-system)
- (inputs `(("perl-test-tester" ,perl-test-tester)
- ("perl-test-nowarnings" ,perl-test-nowarnings)))
+ (inputs `(("perl-test-nowarnings" ,perl-test-nowarnings)))
(synopsis "Flexible deep comparison for the Test::Builder framework")
(description
"Test::Deep compares two structures by going through each level, ensuring
@@ -997,7 +997,6 @@ code.")
(base32
"0v385ch0hzz9naqwdw2az3zdqi15gka76pmiwlgsy6diiijmg2k3"))))
(build-system perl-build-system)
- (inputs `(("perl-test-tester" ,perl-test-tester)))
(synopsis "Ensure no warnings are produced while testing")
(description
"This modules causes any warnings during testing to be captured and
@@ -1045,7 +1044,6 @@ usually called epsilon. This module provides such a function for use with
(build-system perl-build-system)
(propagated-inputs
`(("perl-capture-tiny" ,perl-capture-tiny)
- ("perl-test-tester" ,perl-test-tester)
("perl-sub-exporter" ,perl-sub-exporter)))
(synopsis "Utilities to test STDOUT and STDERR messages")
(description
@@ -1239,14 +1237,14 @@ makes fork(2) safe to use in test cases.")
(define-public perl-test-simple
(package
(name "perl-test-simple")
- (version "1.302169")
+ (version "1.302171")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/"
"Test-Simple-" version ".tar.gz"))
(sha256
(base32
- "08y7b817045w9bc1k9y01l5shl162q9fdc2g5qf7ny0gdxvh85s1"))))
+ "12in730hr51h42dwd3c5k7ysyp0xyk17583mfvx6zg56nb990zz2"))))
(build-system perl-build-system)
(synopsis "Basic utilities for writing tests")
(description
@@ -1341,8 +1339,7 @@ cause a test fail unless it is exactly as @code{perltidy} would like it to be.")
`(("perl-module-build" ,perl-module-build)
("perl-test-simple" ,perl-test-simple)))
(propagated-inputs
- `(("perl-test-tester" ,perl-test-tester)
- ("perl-data-dump" ,perl-data-dump)))
+ `(("perl-data-dump" ,perl-data-dump)))
(home-page "https://metacpan.org/release/Test-Trap")
(synopsis "Trap exit codes, exceptions, output, and so on")
(description "This module is primarily (but not exclusively) for use in