summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-08-04 08:16:38 -0400
committerMark H Weaver <mhw@netris.org>2016-08-04 08:16:38 -0400
commit0832787e5c463c713d8f24fdec0f52900ff1c2bd (patch)
tree5ce20bef711d0d85a22cd041758278d7c176b0f3 /gnu/packages/perl.scm
parent5b098cc4b937c05d6f685772c66e2aa04490710a (diff)
Revert "Merge branch 'core-updates'"
This reverts commit 455859a50f88f625d13fc2f304111f02369b366b.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm39
1 files changed, 10 insertions, 29 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4423c77bbd..08a16ad2af 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -90,7 +90,15 @@
"-Dinstallstyle=lib/perl5"
"-Duseshrplib"
(string-append "-Dlocincpth=" libc "/include")
- (string-append "-Dloclibpth=" libc "/lib"))))))
+ (string-append "-Dloclibpth=" libc "/lib")
+
+ ;; Force the library search path to contain only libc
+ ;; because it is recorded in Config.pm and
+ ;; Config_heavy.pl; we don't want to keep a reference
+ ;; to everything that's in $LIBRARY_PATH at build
+ ;; time (Binutils, bzip2, file, etc.)
+ (string-append "-Dlibpth=" libc "/lib")
+ (string-append "-Dplibpth=" libc "/lib"))))))
(add-before
'strip 'make-shared-objects-writable
@@ -101,34 +109,7 @@
(lib (string-append out "/lib")))
(for-each (lambda (dso)
(chmod dso #o755))
- (find-files lib "\\.so$")))))
-
- (add-after 'install 'remove-extra-references
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (libc (assoc-ref inputs "libc"))
- (config1 (car (find-files (string-append out "/lib/perl5")
- "^Config_heavy\\.pl$")))
- (config2 (find-files (string-append out "/lib/perl5")
- "^Config\\.pm$")))
- ;; Force the library search path to contain only libc because
- ;; it is recorded in Config.pm and Config_heavy.pl; we don't
- ;; want to keep a reference to everything that's in
- ;; $LIBRARY_PATH at build time (GCC, Binutils, bzip2, file,
- ;; etc.)
- (substitute* config1
- (("^incpth=.*$")
- (string-append "incpth='" libc "/include'\n"))
- (("^(libpth|plibpth|libspath)=.*$" _ variable)
- (string-append variable "='" libc "/lib'\n")))
-
- (for-each (lambda (file)
- (substitute* config2
- (("libpth => .*$")
- (string-append "libpth => '" libc
- "/lib',\n"))))
- config2)
- #t))))))
+ (find-files lib "\\.so$"))))))))
(native-search-paths (list (search-path-specification
(variable "PERL5LIB")
(files '("lib/perl5/site_perl")))))