summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-25 13:50:26 +0200
committerRoel Janssen <roel@gnu.org>2021-05-25 13:50:26 +0200
commitbc13e794763991e1883751bfdb1e7a48195cba97 (patch)
tree19f89ac25896244246cd076df335b3614cc6d058 /gnu/packages/perl.scm
parenta154048d980ada9b7dcc35e35cbe75056a0cd756 (diff)
gnu: Add perl-const-fast.
* gnu/packages/perl.scm (perl-const-fast): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d35508112f..0e18c73138 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
-;;; Copyright © 2016, 2018, 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2018, 2020, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
@@ -1918,6 +1918,32 @@ of the style used by the Git version control system.")
and writing of @code{.ini}-style configuration files.")
(license (package-license perl))))
+(define-public perl-const-fast
+ (package
+ (name "perl-const-fast")
+ (version "0.014")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/L/LE/LEONT/"
+ "Const-Fast-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nwlldgrx86yn7y6a53cqgvzm2ircsvxg1addahlcy6510x9a1gq"))))
+ (inputs
+ `(("perl-module-build-tiny" ,perl-module-build-tiny)
+ ("perl-test-fatal" ,perl-test-fatal)))
+ ;; Needed for tests.
+ (native-inputs
+ `(("perl-sub-exporter-progressive" ,perl-sub-exporter-progressive)))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Const-Fast")
+ (synopsis "Facility for creating read-only scalars, arrays, and hashes")
+ (description "This package provides prodecures to create read-only
+scalars, arrays, and hashes.")
+ (license (package-license perl))))
+
(define-public perl-context-preserve
(package
(name "perl-context-preserve")