summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-01-28 14:21:12 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-02-11 21:13:36 +0100
commit4d4fad681983a1a44da3a7a5c032cb26febd3ef2 (patch)
treea307885adf78b9be92b1318a9786afe39a1d153c /gnu/packages/php.scm
parentc8423a5457a846e42634a9a644916abfeceab5f2 (diff)
gnu: php: Update to 8.2.2.
* gnu/packages/php.scm (php): Update to 8.2.2. * gnu/packages/patches/php-curl-compat.patch: Remove file. * gnu/packages/patches/php-bug-74093-test.patch: Remove file. * gnu/packages/patches/php-fix-streams-copy-length.patch: New file. * gnu/local.mk (dist_patch_DATA): Remove them. Add it.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm46
1 files changed, 35 insertions, 11 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 645a8edee1..e0cd47b846 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -61,17 +61,17 @@
(define-public php
(package
(name "php")
- (version "7.4.30")
- (home-page "https://secure.php.net/")
+ (version "8.2.2")
+ (home-page "https://www.php.net/")
(source (origin
(method url-fetch)
(uri (string-append home-page "distributions/"
"php-" version ".tar.xz"))
(sha256
(base32
- "03d7icwys4ikl45q3rgsxv1m3i7kfxhykpx75nn7jzn6697s6wpa"))
- (patches (search-patches "php-bug-74093-test.patch"
- "php-curl-compat.patch"))
+ "0czflx9ikxymjfgnzaifjx9kc30ww2x4063075hcifjjwqwami5x"))
+ (patches
+ (search-patches "php-fix-streams-copy-length.patch"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -83,8 +83,7 @@
;;"bcmath/libbcmath"
;;"fileinfo/libmagic" ; a patched version of libmagic
'("gd/libgd"
- "pcre/pcre2lib"
- "xmlrpc/libxmlrpc"))))))
+ "pcre/pcre2lib"))))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -176,12 +175,13 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
- ,@(if (string-prefix? "arm" (or (%current-system)
- (%current-target-system)))
+ ,@(if (target-arm32?)
;; Drop tests known to fail on armhf.
'((for-each delete-file
(list
"ext/calendar/tests/unixtojd_error1.phpt"
+ "ext/opcache/tests/preload_006.phpt"
+ "ext/opcache/tests/preload_011.phpt"
;; arm can be a lot slower, so a time-related test fails
"ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
"ext/pcntl/tests/pcntl_unshare_01.phpt"
@@ -199,6 +199,13 @@
"Zend/tests/concat_003.phpt")))
'())
+ ,@(if (target-x86-32?)
+ ;; Drop tests known to fail on i686.
+ '((for-each delete-file
+ (list
+ "ext/dba/tests/dba_gdbm.phpt")))
+ '())
+
,@(if (target-ppc64le?)
;; Drop tests known to fail on powerpc64le.
'((for-each delete-file
@@ -272,8 +279,6 @@
;; Some WebP related tests fail.
"ext/gd/tests/webp_basic.phpt"
"ext/gd/tests/imagecreatefromstring_webp.phpt"
- ;; Expected error message, but from the wrong function
- "ext/gd/tests/bug77269.phpt"
;; TODO: Enable these when libgd is built with xpm support.
"ext/gd/tests/xpm2gd.phpt"
"ext/gd/tests/xpm2jpg.phpt"
@@ -291,6 +296,14 @@
;; The following test fails with "The image size
;; differs: expected 114x115, got 117x117".
"ext/gd/tests/bug79068.phpt"
+ ;; AVIF support disabled
+ "ext/gd/tests/avif_decode_encode.phpt"
+ ;; Typo in expected outputs
+ "ext/gd/tests/bug72339.phpt"
+ "ext/gd/tests/bug77272.phpt"
+ "ext/gd/tests/bug66356.phpt"
+ ;; AVIF support disabled
+ "ext/gd/tests/imagecreatefromstring_avif.phpt"
;; XXX: These iconv tests have the expected outcome,
;; but with different error messages.
@@ -310,6 +323,17 @@
;; XXX: These test failures appear legitimate, needs investigation.
;; open_basedir() restriction failure.
"ext/curl/tests/bug61948-unix.phpt"
+ ;; Same error reason but error code slightly different
+ "ext/curl/tests/curl_setopt_ssl.phpt"
+
+ ;; Fail because there is no "root" in the build container's
+ ;; /etc/passwd
+ "sapi/fpm/tests/bug68591-conf-test-group.phpt"
+ "sapi/fpm/tests/bug68591-conf-test-listen-group.phpt"
+ "sapi/fpm/tests/bug68591-conf-test-listen-owner.phpt"
+
+ ;; Wrong error name
+ "ext/dba/tests/dba_gdbm_creation_matrix.phpt"
;; Expects a false boolean, gets empty array from glob().
"ext/standard/tests/file/bug41655_1.phpt"
"ext/standard/tests/file/glob_variation5.phpt"