summaryrefslogtreecommitdiff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-23 17:33:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-23 17:33:54 +0200
commit40fb160a5e8b0b800426489c0a2ad387c6934fba (patch)
tree9fd1a464ed70707a1967db9f40274206d77bb750 /gnu/packages/pretty-print.scm
parente3f4ab49b1b756d3356b142db935b684e6877346 (diff)
Revert "gnu: source-highlight: Wrap scripts."
This package causes the rebuild of more than 9000 packages. This reverts commit 367bc2d198f57bc34522441820f761b61fed0ce0.
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 8afe73da45..34d413f8c9 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2019, 2020, 2024 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -47,7 +47,6 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gperf)
#:use-module (gnu packages groff)
- #:use-module (gnu packages guile)
#:use-module (gnu packages gv)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
@@ -305,7 +304,7 @@ a fast alternative to @code{IOStreams}.")
;; The ctags that comes with emacs does not support the --excmd options,
;; so can't be used
(inputs
- (list boost guile-3.0))
+ (list boost))
(native-inputs
(list bison flex))
(arguments
@@ -337,15 +336,7 @@ a fast alternative to @code{IOStreams}.")
(substitute* '("tests/test.sh.html"
"tests/test2.sh.html"
"tests/test.tcl.html")
- (("#! */bin/sh") "#!/bin/sh"))))
- (add-after 'install 'wrap-scripts
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each
- (lambda (script)
- (wrap-script (string-append #$output "/bin/" script)
- `("PATH" ":" prefix (,(string-append #$output "/bin")))))
- (list "cpp2html" "java2html" "source-highlight-esc.sh"
- "src-hilite-lesspipe.sh")))))))
+ (("#! */bin/sh") "#!/bin/sh")))))))
(home-page "https://www.gnu.org/software/src-highlite/")
(synopsis "Produce a document with syntax highlighting from a source file")
(description