summaryrefslogtreecommitdiff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-03 12:35:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-03 13:09:58 +0200
commit996f2a1609b8d9e17bcc2e0a9bea6a87fb4662c7 (patch)
treeb35b395d492a6d8c548fadbc56cea10f22c2640e /gnu/packages/pretty-print.scm
parent637c5d8219e254e8ba1b37d092f1b082ff7ddeaa (diff)
gnu: a2ps: Improve package style.
* gnu/packages/pretty-print.scm (a2ps)[origin]<snippet>: Use G-expressions. [arguments]<#:phases>: Use G-expression and SEARCH-INPUT-FILE.
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm79
1 files changed, 40 insertions, 39 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 365743261b..ea1d26e8d7 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -27,6 +27,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages pretty-print)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix licenses)
#:use-module (guix git-download)
@@ -65,46 +66,46 @@
(modules '((guix build utils)))
(snippet
;; Remove timestamp from the installed 'README' file.
- '(begin
- (substitute* "etc/README.in"
- (("@date@")
- "1st of some month, sometime after 1970"))))))
+ #~(begin
+ (substitute* "etc/README.in"
+ (("@date@")
+ "1st of some month, sometime after 1970"))))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-tests
- (lambda _
- (substitute* (list "tests/Makefile.am" "tests/Makefile.in")
- (("(encoding|prolog-2)\\.tst") ""))))
- (add-before 'build 'patch-scripts
- (lambda _
- (substitute*
- '("afm/make_fonts_map.sh"
- "tests/defs"
- "tests/backup.tst"
- "tests/styles.tst")
- (("/bin/rm") (which "rm")))))
- (add-before 'check 'patch-test-files
- ;; Alternatively, we could unpatch the shebangs in tstfiles
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((perl (assoc-ref inputs "perl")))
- (substitute* '("tests/ps-ref/includeres.ps"
- "tests/gps-ref/includeres.ps")
- (("/usr/local/bin/perl")
- (string-append perl "/bin/perl"))))
- ;; Some of the reference postscript contain a 'version 3'
- ;; string that in inconsistent with the source text in the
- ;; tstfiles directory. Erroneous search-and-replace?
- (substitute* '("tests/ps-ref/InsertBlock.ps"
- "tests/gps-ref/InsertBlock.ps"
- "tests/ps-ref/bookie.ps"
- "tests/gps-ref/bookie.ps")
- (("version 3") "version 2"))
- (substitute* '("tests/ps-ref/psmandup.ps"
- "tests/gps-ref/psmandup.ps")
- (("#! */bin/sh") (string-append
- "#!" (which "sh")))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (substitute* (list "tests/Makefile.am" "tests/Makefile.in")
+ (("(encoding|prolog-2)\\.tst") ""))))
+ (add-before 'build 'patch-scripts
+ (lambda _
+ (substitute*
+ '("afm/make_fonts_map.sh"
+ "tests/defs"
+ "tests/backup.tst"
+ "tests/styles.tst")
+ (("/bin/rm") (which "rm")))))
+ (add-before 'check 'patch-test-files
+ ;; Alternatively, we could unpatch the shebangs in tst files.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("tests/ps-ref/includeres.ps"
+ "tests/gps-ref/includeres.ps")
+ (("/usr/local/bin/perl")
+ (search-input-file inputs "/bin/perl")))
+ ;; Some of the reference postscript contain a 'version 3'
+ ;; string that in inconsistent with the source text in the
+ ;; tstfiles directory. Erroneous search-and-replace?
+ (substitute* '("tests/ps-ref/InsertBlock.ps"
+ "tests/gps-ref/InsertBlock.ps"
+ "tests/ps-ref/bookie.ps"
+ "tests/gps-ref/bookie.ps")
+ (("version 3") "version 2"))
+ (substitute* '("tests/ps-ref/psmandup.ps"
+ "tests/gps-ref/psmandup.ps")
+ (("#! */bin/sh")
+ (string-append "#!" (which "sh")))))))))
(native-inputs
(list gperf groff perl pkg-config))
(inputs
@@ -116,7 +117,7 @@
printing. It accomplishes this by being able to delegate files to external
handlers, such as Groff and Gzip. It handles as many steps as is necessary to
produce a pretty-printed file. It also includes some extra abilities for
-special cases, such as pretty-printing \"--help\" output.")
+special cases, such as pretty-printing @samp{-help} output.")
(license gpl3+)))
(define-public trueprint