summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-04-20 17:27:57 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:45 +0200
commit919fdd6fcc18cd5ee68cab5b01c1dacae60bdbec (patch)
treecd9b56d17c7fd59fede4c07641cfdc35c8abe373 /gnu/packages/python-check.scm
parent8ffd8fc64e2fde3288917e390ad541c03b9cae72 (diff)
gnu: Add python-sybil.
* gnu/packages/python-check.scm (python-sybil): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2d35eb720e..8cf1526242 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
+;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2056,3 +2057,31 @@ eliminate flaky failures.")
Python objects. It tries to use the objects available in the standard
@code{unittest} module.")
(license license:expat)))
+
+(define-public python-sybil
+ (package
+ (name "python-sybil")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sybil" version))
+ (sha256
+ (base32 "03ak1w93linfqx6c9lwgq5niyy3j9yblv4ip40hmlzmg0hidq0kg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (native-inputs (list python-pytest python-pytest-cov))
+ (home-page "https://github.com/simplistix/sybil")
+ (synopsis "Automated testing for examples in code and documentation")
+ (description
+ "This library provides a way to check examples in your code and
+documentation by parsing them from their source and evaluating the
+parsed examples as part of your normal test run. Integration is
+provided for the main Python test runners.")
+ (license license:expat)))