summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 10:02:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 10:06:36 +0200
commit04ea577b75adaf4d3110f2909e14eefb5e75cdf7 (patch)
treea351e5683e7d8c8607a1e695d299435c8e1e9333 /gnu/packages/python-crypto.scm
parent5f8491ea95d7ba88801aa28b6d2b98f30b033186 (diff)
gnu: Add python-pyu2f.
* gnu/packages/python-crypto.scm (python-pyu2f): New variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 7f358659f0..0bdcc693ac 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2019, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2016, 2017, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -1699,6 +1699,31 @@ It can create and verify RSA, DSA, and ECDSA signatures, at the moment. It
can also encrypt and decrypt messages using RSA and ECDH.")
(license license:bsd-3)))
+(define-public python-pyu2f
+ (package
+ (name "python-pyu2f")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyu2f" version))
+ (sha256
+ (base32 "0srhzdbgdsqwpcw7awqm19yg3xbabqckfvrp8rbpvz2232hs7jm3"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;none included
+ (propagated-inputs (list python-six))
+ (native-inputs
+ (list python-mock
+ python-pyfakefs
+ python-pytest
+ python-unittest2))
+ (home-page "https://github.com/google/pyu2f/")
+ (synopsis "U2F host library for interacting with a U2F device over USB")
+ (description
+ "Pyu2f is a Python-based U2F host library. It provides functionality for
+interacting with a U2F device over USB.")
+ (license license:asl2.0)))
+
(define-public python-sop
(package
(name "python-sop")