summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-24 18:25:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-24 18:26:26 +0100
commit75c6af85c01affbab094e434a55236bc6ee74c41 (patch)
tree7a1048a9f8b6ed9c00ee6fe4eb702f3afc28b48a /gnu/packages/python-crypto.scm
parentd0f6e8ae7944666469ec1a226df502063d4d0670 (diff)
gnu: python2-cryptography: Remove 'sanity-check phase.
* gnu/packages/python-crypto.scm (python2-cryptography)[arguments]: Do not inherit; remove 'sanity-check phase.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c0cfc00732..74f61fedbf 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -542,6 +542,13 @@ message digests and key derivation functions.")
(let ((crypto (package-with-python2
(strip-python2-variant python-cryptography))))
(package/inherit crypto
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; The sanity-check attempts attempts to import the non-existent
+ ;; modules "_openssl" and "_padding".
+ (delete 'sanity-check))))
(propagated-inputs
`(("python2-ipaddress" ,python2-ipaddress)
("python2-backport-ssl-match-hostname"