summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-18 23:07:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-18 23:07:40 +0100
commit7ba6d70e4528201151195e1ed2175ee4828bdb2f (patch)
tree3a95b7f107763f959c31187d394d3fabbf1501c5 /gnu/packages/python-crypto.scm
parent94c7f70faa0ba0409099b423df6534718d7518cc (diff)
parent6afea7489b76c8db58d4f389fdbedc7c2b8992bd (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index af51ae04b6..63d3be17c2 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -232,16 +232,24 @@ Python interface around SSH networking concepts.")
(define-public python-ecdsa
(package
(name "python-ecdsa")
- (version "0.13.3")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ecdsa" version))
(sha256
- (base32 "0k9xxklf865g6x43gkfarwb25ffrkmpvkzkh71rylqx7cjq80g0n"))))
+ (base32 "13nx5cbfxc0gnax5zwdmp9xc40qd1llk62mv85jyrvqkbw017ik4"))))
(build-system python-build-system)
- (inputs
- `(("openssl" ,openssl)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "pytest"))))))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (native-inputs
+ `(("openssl" ,openssl)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/warner/python-ecdsa")
(synopsis "ECDSA cryptographic signature library (pure python)")
(description