summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-25 18:37:05 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-25 18:37:09 +0100
commita55e18f17cc82a01c11d03bdfb693c62cb068d5c (patch)
tree5bf21d075f3e4120050c26f124056451d264c9db /gnu/packages/python-crypto.scm
parent1e5aabc572256290cb71ab455acdeec477b2e25a (diff)
gnu: Remove python-pycrypto.
The package has seen its last release in 2013 and "is unmaintained, obsolete, and contains security vulnerabilities" according to its homepage. * gnu/packages/python-crypto.scm (python-pycrypto): Delete variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 273e1bf30c..602768ae85 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -240,41 +240,6 @@ messages, and verify the signatures. The keys and signatures are very short,
making them easy to handle and incorporate into other protocols.")
(license license:expat)))
-;;; Pycrypto is abandoned upstream:
-;;;
-;;; https://github.com/dlitz/pycrypto/issues/173
-;;;
-;;; TODO Remove this package from GNU Guix.
-(define-public python-pycrypto
- (package
- (name "python-pycrypto")
- (version "2.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pycrypto" version))
- (patches (search-patches "python-pycrypto-CVE-2013-7459.patch"
- "python-pycrypto-time-clock.patch"))
- (sha256
- (base32
- "0g0ayql5b9mkjam8hym6zyg6bv77lbh66rv1fyvgqb17kfc1xkpj"))))
- (build-system python-build-system)
- (inputs
- (list python gmp))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-build-env
- ;; pycrypto runs an autoconf configure script behind the scenes
- (lambda _ (setenv "CONFIG_SHELL" (which "bash")) #t)))))
- (home-page "https://www.dlitz.net/software/pycrypto/")
- (synopsis "Cryptographic modules for Python")
- (description
- "Pycrypto is a collection of both secure hash functions (such as SHA256
-and RIPEMD160), and various encryption algorithms (AES, DES, RSA, ElGamal,
-etc.). The package is structured to make adding new modules easy.")
- (license license:public-domain)))
-
(define-public python-kerberos
(package
(name "python-kerberos")