summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-16 10:55:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-16 11:14:42 +0300
commite5e0e283ffd92f153303401c39dfcc1d8dde4f96 (patch)
tree82c7f8498081c1f807a0e4a25d0fd75c0e493043 /gnu/packages/python-crypto.scm
parent7c204281ff0b57de59261cd7b68fab3df1c0f49c (diff)
parent40a729a0e6f1d660b942241416c1e2c567616d4d (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm30
1 files changed, 2 insertions, 28 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index bdaee71eb9..df23444489 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
@@ -351,14 +351,10 @@ do what is needed for client/server Kerberos authentication based on
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest"))
- #t)))))
+ (invoke "pytest" "-vv" "-c" "/dev/null" "tests")))))))
(native-inputs
(list python-toml
python-pytest
- python-pytest-checkdocs
- python-pytest-cov
- python-pytest-flake8
python-setuptools
python-setuptools-scm))
(propagated-inputs
@@ -370,30 +366,8 @@ do what is needed for client/server Kerberos authentication based on
service from python. It can be used in any application that needs safe
password storage.")
;; "MIT" and PSF dual license
- (properties `((python2-variant . ,(delay python2-keyring))))
(license license:x11)))
-(define-public python2-keyring
- (let ((keyring (package-with-python2
- (strip-python2-variant python-keyring))))
- (package
- (inherit keyring)
- (name "python2-keyring")
- (version "8.7")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "keyring" version))
- (sha256
- (base32
- "0482rmi2x6p78wl2kz8qzyq21xz1sbbfwnv5x7dggar4vkwxhzfx"))))
- (arguments
- `(#:python ,python-2))
- (native-inputs
- (list python2-pytest python2-pytest-runner python2-setuptools-scm))
- (propagated-inputs
- (list python2-pycrypto)))))
-
(define-public python-keyrings.alt
(package
(name "python-keyrings.alt")