summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-14 14:56:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-14 16:31:44 +0200
commited0e8c7cc92df8deec15edd097c03a82cdc2e58b (patch)
tree255c00979bf67c2445ecf5038002eb3c34672932 /gnu/packages/python-crypto.scm
parent642647ae9305c701b2191a4cbcf28ce583da7d1d (diff)
gnu: python-pgpy: Run the tests.
* gnu/packages/python-crypto.scm (python-pgpy)[arguments]: Replace the default ‘check’ phase. [native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index a86151b485..81a5c213da 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1545,9 +1545,17 @@ signatures.")
(sha256
(base32 "11rrq15gmn6qbahli7czflfcngjl7zyybjlvk732my6axnf2d754"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
(native-inputs
`(("python-cryptography" ,python-cryptography)
("python-pyasn1" ,python-pyasn1)
+ ("python-pytest" ,python-pytest)
("python-singledispatch" ,python-singledispatch)
("python-six" ,python-six)
("python-wheel" ,python-wheel)))