summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-14 14:19:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-15 09:29:33 +0200
commitf7c966ae02b4915d968b8f9769c506b1c77a17ff (patch)
tree5674f028a8d01e7d1c03930b7b0d3d4ee600d9fd /gnu/packages/python-crypto.scm
parentd9784b1a63ad26b5b54ef605f77933eea6de44a7 (diff)
gnu: python-keyring: Make tests skippable.
* gnu/packages/python-crypto.scm (python-keyring)[arguments]: In custom 'check phase only run tests when tests? is #true.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 9739de1dde..bf39f124a1 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -382,8 +382,10 @@ do what is needed for client/server Kerberos authentication based on
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"))
+ #t)))))
(native-inputs
`(("python-toml" ,python-toml)
("python-pytest" ,python-pytest)