summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:39:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:10 +0300
commit12c529c071762dc80ef0439a1c94422cfa26af57 (patch)
tree6d335c7d1e04291c93f31d36281cd20fa3859912 /gnu/packages/python-science.scm
parent4a23812c7cbfed854626c1dd5a557933e8fd5ad3 (diff)
gnu: python-bottleneck: Honor #:tests? flag.
* gnu/packages/python-science.scm (python-bottleneck)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ef9f672f1f..c9f122c5c9 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -580,8 +580,9 @@ Python module with the same interface, but (hopefully) faster.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "setup.py" "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "setup.py" "pytest")))))))
(native-inputs
(list python-hypothesis python-pytest python-pytest-runner))
(propagated-inputs