summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-10 14:54:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:07 +0200
commit96c51a9dbfda0a08a2f2cdbd1f62e1c064d22437 (patch)
tree8160aa502045072025c7cb80c67b24a62e344bcb /gnu/packages/python-science.scm
parentff3c55bb98c1b9629061af8f8d3848bc6faea064 (diff)
gnu: python-scikit-optimize: Fix build with newer numpy and sklearn.
* gnu/packages/patches/python-scikit-optimize-1148.patch, gnu/packages/patches/python-scikit-optimize-1150.patch: New patches. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/python-science.scm (python-scikit-optimize)[source]: Fetch with git and apply patches.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c9f122c5c9..0e099989c8 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -290,11 +290,19 @@ logic, also known as grey logic.")
(name "python-scikit-optimize")
(version "0.9.0")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "scikit-optimize" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/scikit-optimize/scikit-optimize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0230ya8bwrzxjwcy2vz23a3hg6caggnnmg2vq1f9zz2797kckn3p"))))
+ "0hsq6pmryimxc275yrcy4bv217bx7ma6rz0q6m4138bv4zgq18d1"))
+ (patches
+ ;; These are for compatibility with more recent versions of
+ ;; numpy and scikit-learn.
+ (search-patches "python-scikit-optimize-1148.patch"
+ "python-scikit-optimize-1150.patch"))))
(build-system pyproject-build-system)
(propagated-inputs
(list python-joblib