summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 11:13:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 13:36:47 +0100
commit994817bfdccc715dccfa96366fc286a80171a7e6 (patch)
tree6448e9af29111a13a1311ee5af27b91835ee5704 /gnu/packages/python-science.scm
parent2eb061be7981789199990f93058fa070728aad18 (diff)
gnu: python-scipy: Update to 1.12.0.
* gnu/packages/python-science.scm (python-scipy): Update to 1.12.0. [propagated-inputs]: Add python-jupytext, python-mpmath, python-mypy, python-numpydoc, python-pydata-sphinx-theme, python-pydevtool, python-rich-click, python-sphinx, python-threadpoolctl, and python-typing-extensions; remove python-pyparsing. [native-inputs]: Add python-hypothesis, python-pycodestyle, python-pytest-cov, and python-pytest-xdist; remove python-threadpoolctl. Change-Id: I81a4831e3d94c58416f7d35ec47de90370b88210
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ef65ed537a..1f00ad880b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -84,13 +84,13 @@
(define-public python-scipy
(package
(name "python-scipy")
- (version "1.11.4")
+ (version "1.12.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "scipy" version))
(sha256
- (base32 "1amfxpnni0cagwjpb0i1kdgnh4sh484ryn4gfkgbjcspgy7bg8lh"))))
+ (base32 "18rn15wg3lp58z204fbjjhy0h79c53yg3c4qqs9h3liniamspxab"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -135,7 +135,19 @@
(copy-recursively "build/html" html)))
(format #t "sphinx-build not found, skipping~%"))))))))
(propagated-inputs
- (list python-numpy python-matplotlib python-pyparsing python-pythran))
+ (list python-jupytext
+ python-matplotlib
+ python-mpmath
+ python-mypy
+ python-numpy
+ python-numpydoc
+ python-pydata-sphinx-theme
+ python-pydevtool
+ python-pythran
+ python-rich-click
+ python-sphinx
+ python-threadpoolctl
+ python-typing-extensions))
(inputs (list openblas pybind11-2.10))
(native-inputs
(list gfortran
@@ -147,11 +159,14 @@
python-click
python-cython-0.29.35
python-doit
+ python-hypothesis
python-pooch
+ python-pycodestyle
python-pydevtool
python-pytest
- python-pytest-xdist
- python-threadpoolctl))
+ python-pytest-cov
+ python-pytest-timeout
+ python-pytest-xdist))
(home-page "https://scipy.org/")
(synopsis "The Scipy library provides efficient numerical routines")
(description "The SciPy library is one of the core packages that make up