summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-20 14:55:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-20 22:03:03 +0000
commite1d3be4113c854d6efdfda6a8c3e5757753425ad (patch)
tree46e3a52cc4fd100ce46abb4d12513a1dbd88cd24 /gnu/packages/python-science.scm
parent7c540ed1065bf998ed41b515042fa1b3f30f80fe (diff)
gnu: python-pandera: Fix build.
* gnu/packages/python-science.scm (python-pandera): Fix build. [source]: Delete tests/modin directory. [native-inputs]: Remove python-modin. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 4eb0195889..3422302a87 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -661,16 +661,20 @@ a convention of suggesting best recommended practices for using
(sha256
(base32 "1mnqk583z90k1n0z3lfa4rd0ng40v7hqfk7phz5gjmxlzfjbxa1x"))
(modules '((guix build utils)))
- ;; These tests require PySpark. We need to remove the entire directory,
- ;; since the conftest.py in this directory contains a PySpark import.
- ;; (See: https://github.com/pytest-dev/pytest/issues/7452)
- (snippet '(delete-file-recursively "tests/pyspark"))))
+ ;; These tests require PySpark and Modin. We need to remove the entire
+ ;; directory, since the conftest.py in these directories contain
+ ;; imports. (See: https://github.com/pytest-dev/pytest/issues/7452)
+ (snippet '(begin
+ (delete-file-recursively "tests/pyspark")
+ (delete-file-recursively "tests/modin")))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags '(list "-k"
(string-append
- ;; Needs python-pandas >= 1.5
+ ;; Mypy functionality is experimental and relying
+ ;; on pandas-stubs can lead to false
+ ;; positives. These tests currently fail.
"not test_python_std_list_dict_generics"
" and not test_python_std_list_dict_empty_and_none"
" and not test_pandas_modules_importable"))))
@@ -692,7 +696,6 @@ a convention of suggesting best recommended practices for using
(native-inputs (list python-dask ;dask extra
python-fastapi ;fastapi extra
python-geopandas ;geopandas extra
- python-modin ;modin extra
python-pyarrow ;needed to run fastapi tests
python-pytest
python-pytest-asyncio