summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-07-20 19:13:48 +0200
committerMathieu Othacehe <othacehe@gnu.org>2023-10-05 17:23:48 +0200
commit21f3f301412153d64747044572c8024eeea07248 (patch)
tree58f6a31d02556724e2ba8c53ee27caee91c2cb0f /gnu/packages/python-web.scm
parent9917079bd708deed1e797a60eb549b1586d60962 (diff)
gnu: Add python-pynetbox.
* gnu/packages/python-web.scm (python-pynetbox): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9939a994b6..ca5b490bd8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8820,3 +8820,28 @@ Grid5000 resources interactively using the embedded shell.")
scientific testbeds. It lets you deploy networks of machines on actual
hardware on Grid'5000 or via OpenStack, to Vagrant, Chameleon, and more.")
(license license:gpl3+)))
+
+(define-public python-pynetbox
+ (package
+ (name "python-pynetbox")
+ (version "7.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pynetbox" version))
+ (sha256
+ (base32
+ "16ps9zgcjzyzn95lry277741i8php4ci3plsyd2vqxd57havba7b"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; Integration tests depend on docker.
+ (delete-file-recursively "tests/integration"))))))
+ (propagated-inputs (list python-requests))
+ (native-inputs (list python-pytest python-pyyaml python-setuptools-scm))
+ (home-page "https://github.com/netbox-community/pynetbox")
+ (synopsis "NetBox API client library")
+ (description "Python module to query and edit data stored in a
+@url{https://netbox.dev,NetBox} instance.")
+ (license license:asl2.0)))