summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-16 18:20:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-16 20:12:06 +0200
commit702a10125724c2af7eadfab3a9edf71c3d32936b (patch)
tree410d7aed53005feddd57c597c4604ddf66f50e8d /gnu/packages/python-web.scm
parent228d29010679b3090cf359fd3d21d7f5bc33b008 (diff)
gnu: Use HTTPS for github.com (and subdomains) home pages.
* gnu/packages/bioconductor.scm (r-qvalue)[home-page]: Use HTTPS and follow permanent redirection. * gnu/packages/check.scm (python-codecov, python-nosexcover) [home-page]: Likewise. * gnu/packages/cran.scm (r-ffbase, r-ggrepel, r-valr) [home-page]: Likewise. * gnu/packages/crates-io.scm (rust-block-0.1, rust-dispatch-0.1) (rust-objc-0.2, rust-objc-exception-0.1) (rust-objc-foundation-0.1, rust-objc-id-0.1, rust-objc-test-utils-0.0) (rust-onig-5.0, rust-onig-sys-69.2, rust-vergen-3.1) [home-page]: Likewise. * gnu/packages/finance.scm (ledger-agent, keepkey-agent) [home-page]: Likewise. * gnu/packages/haskell-check.scm (ghc-tasty-expected-failure) [home-page]: Likewise. * gnu/packages/haskell-web.scm (ghc-bsb-http-chunked, ghc-warp) (ghc-warp-tls)[home-page]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-configurator, ghc-hasktags) (ghc-linear, ghc-newtype-generics, ghc-retry, ghc-xdg-basedir) (ghc-pretty-show)[home-page]: Likewise. * gnu/packages/java.scm (java-javax-inject)[home-page]: Likewise. * gnu/packages/libffi.scm (ruby-ffi)[home-page]: Likewise. * gnu/packages/linux.scm (procenv)[home-page]: Likewise. * gnu/packages/python-web.scm (python-aiodns, python-flask-htpasswd) (python-pycares)[home-page]: Likewise. * gnu/packages/python-xyz.scm (python-progressbar33, python-whatever) (python-funcy)[home-page]: Likewise. * gnu/packages/ruby.scm (ruby-rubyzip, ruby-spinach, ruby-gherkin-ruby) (ruby-code-statistics, ruby-colorize, ruby-wwtd)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1d7cfd852d..0624cc967a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -187,7 +187,7 @@ aiohttp. It supports SOCKS4(a) and SOCKS5.")
`(("python-pycares" ,python-pycares)))
(arguments
`(#:tests? #f)) ;tests require internet access
- (home-page "http://github.com/saghul/aiodns")
+ (home-page "https://github.com/saghul/aiodns")
(synopsis "Simple DNS resolver for asyncio")
(description "@code{aiodns} provides a simple way for doing
asynchronous DNS resolutions with a synchronous looking interface by
@@ -2368,7 +2368,7 @@ pretty printer and a tree visitor.")
("python-itsdangerous" ,python-itsdangerous)
("python-passlib" ,python-passlib)
("python-tox" ,python-tox)))
- (home-page "http://github.com/carsongee/flask-htpasswd")
+ (home-page "https://github.com/carsongee/flask-htpasswd")
(synopsis "Basic authentication via htpasswd files in Flask applications")
(description "This package provides Basic authentication via
@file{htpasswd} files and access_token authentication in Flask
@@ -3106,7 +3106,7 @@ more.")
(build-system python-build-system)
(arguments
`(#:tests? #f)) ;tests require internet access
- (home-page "http://github.com/saghul/pycares")
+ (home-page "https://github.com/saghul/pycares")
(synopsis "Python interface for @code{c-ares}")
(description "@code{pycares} is a Python module which provides an
interface to @code{c-ares}, a C library that performs DNS requests and