summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-09-11 19:24:53 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-11 19:45:05 -0400
commit73f68c1a45bbdbd64633d5cc05f5dcf4080d581a (patch)
treebdd5ddbb532d9489539f412c405b76600a2361a7 /gnu/packages/python-web.scm
parent87ec1ae95c308e7ee5e060ec3b76ef111c6ff08f (diff)
gnu: python-wtforms: Update to 2.3.3 and adjust arguments+inputs.
* gnu/packages/python-web.scm (python-wtforms)[version]: Update to 2.3.3. [phases](remove-django-test): Remove phase. (check): Replace with custom phase. [native-inputs]: Remove unzip. Add python-coverage, python-dateutil, python-pep8 and python-sqlalchemy. [propagated-inputs]: Add python-babel, python-email-validaor and python-markupsafe. Co-authored-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32b4aa4bf0..bd390d371d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4150,28 +4150,33 @@ addon modules.")
(define-public python-wtforms
(package
(name "python-wtforms")
- (version "2.1")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "WTForms" version ".zip"))
+ (uri (pypi-uri "WTForms" version ".tar.gz"))
(sha256
(base32
- "0vyl26y9cg409cfyj8rhqxazsdnd0jipgjw06civhrd53yyi1pzz"))))
+ "17427m7p9nn9byzva697dkykykwcp2br3bxvi8vciywlmkh5s6c1"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-django-test
- ;; Don't fail the tests when the inputs for the optional tests cannot be found.
- (lambda _
- (substitute*
- "tests/runtests.py"
- (("'ext_django.tests', 'ext_sqlalchemy', 'ext_dateutil', 'locale_babel'") "")
- (("sys.stderr.write(\"### Disabled test '%s', dependency not found\n\" % name)") ""))
- #t)))))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "setup.py" "compile_catalog")
+ (invoke "coverage" "run" "tests/runtests.py" "--with-pep8")))))))
(native-inputs
- `(("unzip" ,unzip)))
+ `(("python-coverage" ,python-coverage)
+ ("python-dateutil" ,python-dateutil)
+ ("python-pep8" ,python-pep8)
+ ("python-sqlalchemy" ,python-sqlalchemy)))
+ (propagated-inputs
+ `(("python-babel" ,python-babel)
+ ("python-email-validator" ,python-email-validator)
+ ("python-markupsafe" ,python-markupsafe)))
(home-page "http://wtforms.simplecodes.com/")
(synopsis
"Form validation and rendering library for Python web development")