summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-09 15:58:51 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-16 07:58:51 +0200
commitcb46336c40d695b87218b2136d670eacd7a519fc (patch)
treec9131365ab3daca1b73a796bc2031cc5cc4d8c0a /gnu/packages/python-web.scm
parentd08bd19de0b06d5da7f2c06fb733e245b566dd54 (diff)
gnu: Add python-ovh.
* gnu/packages/python-web.scm (python-ovh): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 61a21f9c94..6f855a503b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -778,6 +778,34 @@ Model} (SAM) templates into AWS CloudFormation templates.")
emit information from within their applications to the AWS X-Ray service.")
(license license:asl2.0)))
+(define-public python-ovh
+ (package
+ (name "python-ovh")
+ (version "1.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ovh" version))
+ (sha256
+ (base32
+ "0ygniv12lixh9rvnjcd01gzbzk2b5xwcg2a59b7964a77dd9p3qh"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ; XXX: tests require networking
+ (propagated-inputs (list python-requests))
+ (native-inputs (list python-black
+ python-coverage
+ python-flake8
+ python-isort
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-sphinx
+ python-wheel))
+ (home-page "https://api.ovh.com")
+ (synopsis "Interact with OVHcloud APIs")
+ (description "This package provides the official module to perform HTTP requests
+to the OVHcloud APIs.")
+ (license license:bsd-3)))
+
(define-public python-cbor2
(package
(name "python-cbor2")