summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-18 00:19:51 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-18 00:19:51 -0400
commitf2cc76c8090b0c5b1835dbe1c1c75821a0595652 (patch)
tree3567b3cc2ece836c5003e54da05259e3232f6bd6 /gnu/packages/python-web.scm
parentaaf85222f108b868f095ef0e7400e219b945d032 (diff)
gnu: python-httplib2: Update to 0.22.0.
* gnu/packages/python-web.scm (python-httplib2): Update to 0.22.0. [build-system]: Switch to pyproject-build-system. [native-inputs]: Add python-cryptography.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c7ccdcd5af..a983009953 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1045,7 +1045,7 @@ over a different origin than that of the web application.")
(define-public python-httplib2
(package
(name "python-httplib2")
- (version "0.15.0")
+ (version "0.22.0")
(source
(origin
;; Tests not included in the release tarball.
@@ -1056,8 +1056,8 @@ over a different origin than that of the web application.")
(file-name (git-file-name name version))
(sha256
(base32
- "11bis23xqbl6aa5m5yswwcf6zn4j24lyi7bfskd31h4zb368ggsj"))))
- (build-system python-build-system)
+ "1zkp3glv0iha7p68p5m0sb8mrrammkdc0mx32517xry52s4iva7g"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
@@ -1067,7 +1067,8 @@ over a different origin than that of the web application.")
(substitute* "requirements-test.txt"
(("==") ">=")))))))
(native-inputs
- (list python-flake8
+ (list python-cryptography
+ python-flake8
python-future
python-mock
python-pytest