summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-09-25 03:49:06 -0400
committerArun Isaac <arunisaac@systemreboot.net>2021-09-29 00:09:47 +0530
commit009f0fc3dde0c2162c6df02fc4790a9f1d909e99 (patch)
tree2f91b9db707b83f28ddf6982595fb1784f5e4eee /gnu/packages/python-xyz.scm
parentea75da9ec9b423b37a0f02691b3d5da8798be834 (diff)
gnu: Add python-glom.
* gnu/packages/python-xyz.scm (python-glom): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29feffae74..14f5fdef54 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27221,6 +27221,49 @@ command-line applications.
@end itemize")
(license license:bsd-3)))
+(define-public python-glom
+ (package
+ (name "python-glom")
+ (version "20.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "glom" version))
+ (sha256
+ (base32 "04pba09vdr3qjvqvy14g60fscdsi35chbbyqpczdp76cpir101al"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; Make installed executable available for running the tests.
+ (setenv "PATH"
+ (string-append (assoc-ref outputs "out") "/bin"
+ ":" (getenv "PATH")))
+ (invoke "pytest" "-v")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pyyaml" ,python-pyyaml)))
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-boltons" ,python-boltons)
+ ("python-face" ,python-face)))
+ (home-page "https://github.com/mahmoud/glom")
+ (synopsis "Declaratively restructure data")
+ (description "Real applications have real data, and real data
+nests---objects inside of objects inside of lists of objects. glom is a new
+and powerful way to handle real-world data, featuring:
+
+@itemize
+@item Path-based access to nested data structures
+@item Readable, meaningful error messages
+@item Declarative data transformation, using lightweight, Pythonic specifications
+@item Built-in data exploration and debugging features
+@end itemize")
+ (license license:bsd-3)))
+
(define-public python-box
(package
(name "python-box")