summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authordan <i@dan.games>2023-02-03 00:58:14 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-19 09:33:16 +0000
commit044d3f4bef1e36333e5cf9be7d70544fd6501482 (patch)
tree572025b85870f18ca2b791d1a6c4e1c5c4e9cbd7 /gnu/packages/python-xyz.scm
parent228c55cbf0f70ba087a11b9e66e2c52a0388f3c5 (diff)
gnu: Add python-pypytools.
* gnu/packages/python-xyz.scm (python-pypytools): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0e458fdadc..c4a5375839 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11433,6 +11433,27 @@ removal, line continuation, indentation, comment processing, identifier
processing, values parsing, case insensitive comparison, and more.")
(license license:expat)))
+(define-public python-pypytools
+ (package
+ (name "python-pypytools")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pypytools" version))
+ (sha256
+ (base32 "0ag5xyzagprji0m2pkqsfy8539s003mn41pl6plbmh6iwi9w0h51"))))
+ (build-system python-build-system)
+ (arguments (list #:tests? #f)) ; no tests
+ (propagated-inputs (list python-py))
+ (home-page "https://github.com/antocuni/pypytools/")
+ (synopsis
+ "Tools to use PyPy-specific features, with CPython fallbacks")
+ (description
+ "This package provides a collection of useful tools to use PyPy-specific
+features, with CPython fallbacks.")
+ (license license:x11)))
+
(define-public python-simplegeneric
(package
(name "python-simplegeneric")