summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-12-05 22:59:12 +0000
committerChristopher Baines <mail@cbaines.net>2022-12-13 13:42:11 +0000
commit0682e7c2e36933c5447678549c8e61bd1271d92c (patch)
tree33a29c69e6c0f41e555da015ffe930a803bc7e4d /gnu/packages/python-xyz.scm
parent1a0dcc21123c0a9e8c16d0989df1db00092ac3e7 (diff)
gnu: python-h5netcdf: Update to 1.1.0.
* gnu/packages/python-xyz.scm (python-h5netcdf): Update to 1.1.0. [build-system]: Use pyproject-build-system, to simplify package. [description]: Style content and add links to referenced projects. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2279503d63..3ea2763b49 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1759,21 +1759,14 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
(define-public python-h5netcdf
(package
(name "python-h5netcdf")
- (version "1.0.1")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h5netcdf" version))
(sha256
- (base32 "1b2dcgf5rwy7pb7hr4prkc5vgcw9qc2was20dmnj90lbrpx08rvp"))))
- (build-system python-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "h5netcdf/tests")))))))
+ (base32 "0mmzfr6k55zqxxpb64gvdqisak8s1zb2r04yzkmp0wzd7dbknb4k"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-netcdf4
python-pytest
@@ -1782,9 +1775,11 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
(list python-h5py python-packaging))
(home-page "https://h5netcdf.org")
(synopsis "Python interface for the netCDF4 file-format based on h5py")
- (description "This package provides Python interface for the netCDF4
-file-format that reads and writes local or remote HDF5 files directly via h5py
-or h5pyd, without relying on the Unidata netCDF library")
+ (description "This package provides a Python interface for the netCDF4
+file-format that reads and writes local or remote HDF5 files directly via
+@url{h5py, https://www.h5py.org/} or @url{h5pyd,
+https://github.com/HDFGroup/h5pyd}, without relying on the Unidata netCDF
+library.")
(license license:bsd-3)))
(define-public python-h5py