summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <guix-patches@gnu.org>2022-08-14 18:36:00 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-15 10:22:38 +0200
commit07f807f12c0949e9deeee09b4a28bb1f810b26ca (patch)
treec049757eaeadee876d95b0ca935023323e64c0f3 /gnu/packages/python-xyz.scm
parent18ae404690e8b96c5a97886b506e75c4c1b21b6d (diff)
gnu: python-lsp-server: Update to 1.5.0.
* gnu/packages/python-xyz.scm (python-lsp-server): Update to 1.5.0. [arguments]{set-HOME}: Remove this phase because tests do not require it anymore. {check}: Do not replace it as test_pyqt_completion is not longer failing. [propagated-inputs]: Remove python-future. [native-inputs]: Remove python-mock, python-versioneer and add python-whatthepatch. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5d492d073c..5e8a3654ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5273,30 +5273,19 @@ Server (PLS).")
(define-public python-lsp-server
(package
(name "python-lsp-server")
- (version "1.3.3")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-lsp-server" version))
(sha256
(base32
- "0h6wxzmm6qjfwkkn3mnzn1fpmcp23fpbk74bi8p540q1nzccqj0v"))))
+ "039qi5x9sa1mjzinimxhiwzj8lxn5d5l33q6qhkjl0i5k70r9h75"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-HOME
- (lambda _ (setenv "HOME" "/tmp")))
- (replace 'check
- (lambda _
- ;; Disable failing test.
- (invoke "python" "-m" "pytest" "-k"
- "not test_pyqt_completion"))))))
(propagated-inputs
(list python-autopep8
python-pydocstyle
python-flake8
- python-future
python-jedi
python-lsp-jsonrpc
python-pluggy
@@ -5309,13 +5298,12 @@ Server (PLS).")
(list python-coverage
python-flaky
python-matplotlib
- python-mock
python-numpy
python-pandas
python-pylint
python-pytest
python-pytest-cov
- python-versioneer))
+ python-whatthepatch))
(home-page "https://github.com/python-lsp/python-lsp-server")
(synopsis "Python implementation of the Language Server Protocol")
(description