summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-11 13:44:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:08:54 +0100
commit0fcba8b01c23af756dba5f863db8712d6f840f36 (patch)
tree42c1d1bd5d20fecbbe75ca496b6a37a9d3d792d9 /gnu/packages/python-xyz.scm
parent71dc990f2271dadb8aaa22b87885491466835697 (diff)
gnu: python-marshmallow: Update to 3.19.0.
* gnu/packages/python-xyz.scm (python-marshmallow): Update to 3.19.0. [build-system]: Use pyproject-build-system. [propagated-inputs]: Remove python-dateutil and python-simplejson; add python-packaging. [native-inputs]: Add python-flake8, python-flake8-bugbear, python-mypy, python-pre-commit, and python-simplejson.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2acba1fa39..2d013054ec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20954,24 +20954,29 @@ while only declaring the test-specific fields.")
(define-public python-marshmallow
(package
(name "python-marshmallow")
- (version "3.9.1")
+ (version "3.19.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "marshmallow" version))
- (sha256
- (base32
- "0kizhh3mnhpa08wfnsv1gagy22bpxzxszgbiylkhpz1d8qvwrykk"))))
- (build-system python-build-system)
+ (method url-fetch)
+ (uri (pypi-uri "marshmallow" version))
+ (sha256
+ (base32
+ "0y6vpq2p5841kcw2qil68la0rx9z1vmxzj3dxjv99kjhsq7jq0wh"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-dateutil python-simplejson))
+ (list python-packaging))
(native-inputs
- (list python-pytest python-pytz))
+ (list python-flake8
+ python-flake8-bugbear
+ python-mypy
+ python-pre-commit
+ python-pytest
+ python-pytz
+ python-simplejson))
(home-page "https://github.com/marshmallow-code/marshmallow")
- (synopsis "Convert complex datatypes to and from native
- Python datatypes")
- (description "@code{marshmallow} provides a library for converting
- complex datatypes to and from native Python datatypes.")
+ (synopsis "Convert complex datatypes to and from native Python datatypes")
+ (description "@code{marshmallow} provides a library for converting complex
+datatypes to and from native Python datatypes.")
(license license:expat)))
(define-public python-marshmallow-jsonapi