summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-08 18:53:51 +0200
committerMarius Bakke <marius@gnu.org>2020-06-08 19:01:41 +0200
commit183858d938d60b0ba7ea0ca183f6da153a74864e (patch)
tree0c31e890d79d823108d5e7102f5d7a2a9785e83b /gnu/packages/python-xyz.scm
parenta8a7a2c7972af22457041c36c4c2b4d28621a0e0 (diff)
gnu: python-regex: Update to 2020.6.8.
* gnu/packages/python-xyz.scm (python-regex): Update to 2020.6.8. [arguments]: New field.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d6165e3f3e..abf25c6107 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15105,16 +15105,22 @@ window memory map manager.")
(define-public python-regex
(package
(name "python-regex")
- (version "2019.04.14")
+ (version "2020.6.8")
(source (origin
(method url-fetch)
(uri (pypi-uri "regex" version))
(sha256
(base32
- "1a6hhfs6l6snr1z654ay6wzbmwdkmv282fzfkd5hk2d1n73y8v6m"))))
- ;; TODO: Fix and enable regex_test.py tests that complain about the
- ;; test.support module not existing.
+ "1b3k0zi1pd99q5mk7ri7vcx2y1mq5inm9hk8dryqyhrpkmh4xdp9"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-c"
+ "from regex.test_regex import test_main; test_main()"))))))
(home-page "https://bitbucket.org/mrabarnett/mrab-regex")
(synopsis "Alternative regular expression module")
(description "This regular expression implementation is backwards-