summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-07-28 14:42:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-07-28 20:31:05 +0200
commit2422fbf6b20414819d6d5615f2f18e492bed2f6c (patch)
tree01c8fef06dc71e266461dd60a817ee4a96d821f0 /gnu/packages/python-xyz.scm
parentc486a61c279c5634a09b842570bc6295bf680a6b (diff)
gnu: python2-cloudpickle: Override version, source, and native-inputs.
* gnu/packages/python-xyz.scm (python2-cloudpickle)[version]: Explicitly set to 1.3.0. [source]: Copy from base package. [native-inputs]: Do not inherit; copy.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa16687e24..653d8aa9de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21475,9 +21475,20 @@ data.")
(define-public python2-cloudpickle
(let ((base (package-with-python2 (strip-python2-variant python-cloudpickle))))
(package/inherit base
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cloudpickle" version))
+ (sha256
+ (base32
+ "0lx7gy9clp427qwcm7b23zdsldpr03gy3vxxhyi8fpbhwz859brq"))))
(native-inputs
- `(("python-mock" ,python2-mock)
- ,@(package-native-inputs base)))
+ `(;; For tests.
+ ("python-mock" ,python2-mock)
+ ("python-psutil" ,python2-psutil)
+ ("python-pytest" ,python2-pytest)
+ ("python-tornado" ,python2-tornado)))
(propagated-inputs
`(("python-futures" ,python2-futures)
,@(package-propagated-inputs base))))))