summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 22:25:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 22:47:19 -0400
commit288286e4ce72e4849f63ff34fdd017ed23c633d9 (patch)
treeaac3bdc17b9839aef6a7942a94abb94a0e503119 /gnu/packages/python-xyz.scm
parentc1bbfa75406041e7e3566c1c001892d1188ddd06 (diff)
gnu: python2-jsonschema: Remove package.
* gnu/packages/python-xyz.scm (python2-jsonschema): Delete variable. (python-jsonschema)[properties]: Delete field.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 738b6cb6e2..c7766416e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3410,16 +3410,7 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
(synopsis "Implementation of JSON Schema for Python")
(description
"Jsonschema is an implementation of JSON Schema for Python.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-jsonschema))))))
-
-(define-public python2-jsonschema
- (let ((jsonschema (package-with-python2
- (strip-python2-variant python-jsonschema))))
- (package/inherit jsonschema
- (propagated-inputs
- `(("python2-functools32" ,python2-functools32)
- ,@(package-propagated-inputs jsonschema))))))
+ (license license:expat)))
(define-public python-schema
(package