summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-08-21 00:33:52 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-01 11:50:02 +0200
commit3bf5a19609560c7ba985eda66019eda15aaf4a86 (patch)
treee487abf87167c94390a528c9f43b16e9cf913562 /gnu/packages/python-xyz.scm
parent4a5fbadb88ff18bb7de87b351c6009aaa398a892 (diff)
gnu: python-tox: Move to python-check.
* gnu/packages/python-xyz.scm (python-tox): Move from here... * gnu/packages/python-check.scm (python-tox): ... to here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 181ba975d3..1fa4fd7428 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14608,43 +14608,6 @@ both in documentation and via Python’s warnings system, as well as the
that deprecated code is eventually removed.")
(license license:asl2.0)))
-(define-public python-tox
- (package
- (name "python-tox")
- (version "3.20.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "tox" version))
- (sha256
- (base32
- "0nk0nyzhzamcrvn0qqzzy54isxxqwdi28swml7a2ym78c3f9sqpb"))))
- (build-system python-build-system)
- (arguments
- ;; FIXME: Tests require pytest-timeout, which itself requires
- ;; pytest>=2.8.0 for installation.
- '(#:tests? #f))
- (propagated-inputs
- (list python-filelock
- python-packaging
- python-pluggy
- python-py
- python-six
- python-toml
- python-virtualenv))
- (native-inputs
- (list ; FIXME: Missing: ("python-pytest-timeout" ,python-pytest-timeout)
- python-pytest ; >= 2.3.5
- python-setuptools-scm))
- (home-page "https://tox.readthedocs.io")
- (synopsis "Virtualenv-based automation of test activities")
- (description "Tox is a generic virtualenv management and test command line
-tool. It can be used to check that a package installs correctly with
-different Python versions and interpreters, or run tests in each type of
-supported environment, or act as a frontend to continuous integration
-servers.")
- (license license:expat)))
-
(define-public python-jmespath
(package
(name "python-jmespath")