summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 12:14:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 12:14:16 +0300
commit3fe23854eb2193f5119f4199b887f94d2d36fc72 (patch)
tree7dde35052f0fab807a1ee3f3c97b36c125ce6274 /gnu/packages/python-xyz.scm
parent79ca85d2ff6b977354a2a00e6190b61bbca82f96 (diff)
gnu: python-soupsieve: Fix building.
* gnu/packages/python-xyz.scm (python-soupsieve)[arguments]: Skip sanity check. Convert to gexp.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d710ec9a2a..611451ef55 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -218,6 +218,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix hg-download)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
@@ -8475,10 +8476,15 @@ converts incoming documents to Unicode and outgoing documents to UTF-8.")
(base32
"1k70gpn2d3vgdyxbdy536dgm4kchcraxz6lmgsfg3324iy2789q5"))))
(build-system python-build-system)
- (arguments `(#:tests? #f))
- ;;XXX: 2 tests fail currently despite claming they were to be
- ;;skipped. Also, beautifulsoup4 may depend on this in the future, so we
- ;;don't want to create a circular dependency.
+ (arguments
+ ;;XXX: 2 tests fail currently despite claming they were to be
+ ;;skipped. Also, beautifulsoup4 may depend on this in the future, so we
+ ;;don't want to create a circular dependency.
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Circular dependency with python-beautifulsoup4.
+ (delete 'sanity-check))))
(home-page "https://github.com/facelessuser/soupsieve")
(synopsis "CSS selector library")
(description