summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-22 07:58:25 +0100
committerMarius Bakke <marius@gnu.org>2022-11-22 08:37:26 +0100
commit4147c43a9c10079bdeacedb5ae259990fc0b2f50 (patch)
tree863f49362f1416831155f764fdee59f129edd1d8 /gnu/packages/python-xyz.scm
parent1d7f0a96f47c271f4efd37c23cee827b4cfb9d60 (diff)
gnu: python-py3dns: Fix build failure.
* gnu/packages/python-xyz.scm (python-py3dns)[arguments]: Remove sanity check.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7e667ef7e1..4ee572096f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17633,8 +17633,10 @@ It supports TSIG authenticated messages and EDNS0.")
(lambda _
(substitute* "setup.py"
(("import DNS") "")
- (("DNS.__version__") (string-append "\"" ,version "\"")))
- #t)))
+ (("DNS.__version__") (string-append "\"" ,version "\"")))))
+ ;; For the same reason, drop the sanity check because the library
+ ;; fails to load without /etc/resolv.conf.
+ (delete 'sanity-check))
#:tests? #f)) ; Also skip the tests.
(home-page "https://launchpad.net/py3dns")
(synopsis "Python 3 DNS library")