summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJohn Doe <dftxbs3e@free.fr>2020-12-27 23:26:48 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 13:21:13 +0200
commit51ad28ae71fd4b3d724003f334c0bbd15f60ca65 (patch)
treedf5e693ddffb6536077a3a97bbea1ff3e1abf16b /gnu/packages/python-xyz.scm
parentef5df1588cd4d38da9692b8cd44ffcae679eb6e8 (diff)
gnu: Add python-qdarkstyle.
* gnu/packages/python-xyz.scm (python-qdarkstyle): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8ff0090971..ccd597dd0d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23273,3 +23273,30 @@ query Watchman to discover file changes.")
"Helpdev is a library to easily extract information about the Python
environment.")
(license license:expat)))
+
+(define-public python-qdarkstyle
+ (package
+ (name "python-qdarkstyle")
+ (version "2.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "QDarkStyle" version))
+ (sha256
+ (base32
+ "0883vzg35fzpyl1aiijzpfcdfvpq5vi325w0m7xkx7nxplh02fym"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; Fails unable to detect valid Qt bindings even when
+ ;; added as native-inputs.
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-helpdev" ,python-helpdev)
+ ("python-qtpy" ,python-qtpy)))
+ (home-page
+ "https://github.com/ColinDuquesnoy/QDarkStyleSheet")
+ (synopsis
+ "Complete dark stylesheet for Python and Qt applications")
+ (description "QDarkStyle is the most complete dark stylesheet for Python and
+Qt applications.")
+ (license license:expat)))