summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-07-05 06:52:18 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-06 01:21:45 -0400
commit5d10d84f5ae97029cbc9092e8bed63488abe3d80 (patch)
tree76585cc55671447e245a76d34ca6535963304992 /gnu/packages/python-xyz.scm
parent586136d12745eeddccd05d80dbd21959595b45d1 (diff)
gnu: Add python-ueberzug.
* gnu/packages/python-xyz.scm (python-ueberzug): New variable. Co-authored-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b74b3b808f..aa2406287d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -101,6 +101,7 @@
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
;;;
;;; This file is part of GNU Guix.
@@ -221,6 +222,41 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-ueberzug
+ (package
+ (name "python-ueberzug")
+ (version "18.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ueberzug" version))
+ (sha256
+ (base32
+ "1hxd45dnwa9yv908acarr98n2drmar66wzq9z2qd3irj24srzr3w"))))
+ (build-system python-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxext" ,libxext)))
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-docopt" ,python-docopt)
+ ("python-pillow" ,python-pillow)
+ ("python-xlib" ,python-xlib)))
+ (home-page "https://github.com/seebye/ueberzug")
+ (synopsis "Command line util to display images in combination with X11")
+ (description "Überzug is a command line util which allows to draw images on
+terminals by using child windows. The advantages of using Überzug are:
+@itemize
+@item No race conditions as a new window is created to display images.
+@item Expose events will be processed, so images will be redrawn on switch
+workspaces.
+@item Tmux support (excluding multi pane windows).
+@item Terminals without the WINDOWID environment variable are supported.
+@item Chars are used as position - and size unit.
+@item No memory leak (/ unlimited cache).
+@end itemize")
+ (license license:gpl3+)))
+
(define-public python-fire
(package
(name "python-fire")