summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-25 23:28:57 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:24 +0200
commit6486a66cceabf2c25f1bcfe17ff748dac59ea58c (patch)
tree2c4eafd208771bc797ccfe7ce92065a08785cdd1 /gnu/packages/python-xyz.scm
parentde5b9aefbe7fd20562fb028457dbcf9a4278c79a (diff)
gnu: Add python-xlwt.
* gnu/packages/python-xyz.scm (python-xlwt): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a3d1b74558..6444326efb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10368,6 +10368,37 @@ Unicode-aware. It is not intended as an end-user tool.")
(define-public python2-xlrd
(package-with-python2 python-xlrd))
+(define-public python-xlwt
+ (package
+ (name "python-xlwt")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xlwt" version))
+ (sha256
+ (base32 "123c2pdamshkq75wwvck8fq0cjq1843xd3x9qaiz2a4vg9qi56f5"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) "/build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "nosetests" "-v")))))))
+ (native-inputs
+ `(("nose" ,python-nose)))
+ (home-page "http://www.python-excel.org/")
+ (synopsis "Library for creating spreadsheet Excel files")
+ (description "@code{xlwt} is a library for writing data and formatting
+information to older Excel files (i.e. .xls). The package itself is pure
+Python with no dependencies on modules or packages outside the standard Python
+distribution. It is not intended as an end-user tool.")
+ (license license:bsd-3)))
+
(define-public python-immutables
(package
(name "python-immutables")