summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-11-21 23:48:18 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-24 13:56:28 +0100
commit77a98bcd6ef79151f442f32d73f313e9b86cf9b7 (patch)
tree7d3c7781add86c2451e42506d6ad54c744210161 /gnu/packages/python-xyz.scm
parent993af4a60f4a70847224ea7e7d07d4bc714a668a (diff)
gnu: Add python-commonmark.
* gnu/packages/python-xyz.scm (python-commonmark): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6d63bd34ba..315f7da373 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8892,6 +8892,32 @@ Supported netlink families and protocols include:
(define-public python2-wrapt
(package-with-python2 python-wrapt))
+(define-public python-commonmark
+ (package
+ (name "python-commonmark")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "commonmark" version))
+ (sha256
+ (base32 "0q7d39lm8kcingpmykk5r959hrwwj6v2icyw3mihczxyb749sbs5"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "setup.py" "test"))))))
+ (home-page "https://github.com/readthedocs/commonmark.py")
+ (synopsis "Python parser for the CommonMark Markdown spec")
+ (description
+ "This module is a pure Python port of jgm's @code{commonmark.js}, a
+Markdown parser and renderer for the CommonMark specification, using only
+native modules.")
+ (license license:bsd-3)))
+
(define-public python-xlrd
(package
(name "python-xlrd")