summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 12:51:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:47 +0200
commit7a18bd9e74b56a04ec7e4e120789e91d78830444 (patch)
tree2f245364b9bc842cd22adb37d792c99ba02b3a88 /gnu/packages/python-xyz.scm
parentf37146969a2f24530fcdf270b2d19602809cb4ae (diff)
gnu: Rationalize texlive-updmap.cfg and texlive-tiny inputs.
TEXLIVE-UPDMAP.CFG and TEXLIVE-TINY should only be used as native inputs. Also remove texlive packages already provided by them. * doc/build.scm (pdf-manual): * gnu/packages/algebra.scm (pari-gp): * gnu/packages/bioinformatics.scm (discrover): (phyml): (velvet): * gnu/packages/chemistry.scm (yaehmop): * gnu/packages/chez.scm (stex-bootstrap): (chez-web): (chez-sockets): * gnu/packages/cran.scm (r-prereg): * gnu/packages/docbook.scm (dblatex): * gnu/packages/emacs-xyz.scm (emacs-auctex): * gnu/packages/engineering.scm (fastcap): * gnu/packages/fsf.scm (book-faif): * gnu/packages/graphviz.scm (dot2tex): * gnu/packages/maths.scm (hypre): * gnu/packages/ocaml.scm (unison): (ocaml-bibtex2html): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/python-xyz.scm (python-nbconvert): (python-pypandoc): * gnu/packages/radio.scm (gnuradio): (libosmo-dsp): * gnu/packages/statistics.scm (r-with-tests): * gnu/packages/tex.scm (texlive-makecmds): (texlive-innerscript): (teximpatient): (texlive-xkeyval): Remove texlive packages already provided by TEXLIVE-UPDMAP.CFG. Don't add TEXLIVE-TINY or TEXLIVE-UPDMAP.CFG as inputs.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac560bfcfd..2d8a942309 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15200,17 +15200,15 @@ time.")
texlive-ulem
texlive-unicode-math
texlive-xcolor
- (texlive-updmap.cfg (list texlive-amsfonts
- texlive-amsmath
- texlive-eurosym
- texlive-jknapltx
- texlive-lm
- texlive-lm-math
- texlive-mathpazo
- texlive-oberdiek
- texlive-rsfs
- texlive-ucs
- texlive-zapfding))))
+ (texlive-updmap.cfg
+ (list texlive-eurosym
+ texlive-jknapltx
+ texlive-lm
+ texlive-lm-math
+ texlive-mathpazo
+ texlive-rsfs
+ texlive-ucs
+ texlive-zapfding))))
(home-page "https://jupyter.org")
(synopsis "Converting Jupyter Notebooks")
(description "The @code{nbconvert} tool, @code{jupyter nbconvert}, converts
@@ -29190,13 +29188,7 @@ By default it uses the open Python vulnerability database Safety DB.")
(propagated-inputs
`(("wheel" ,python-wheel)))
(native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
- texlive-ec
- texlive-iftex
- texlive-hyperref
- texlive-lm
- texlive-oberdiek
- texlive-xcolor)))))
+ `(("texlive" ,(texlive-updmap.cfg (list texlive-lm texlive-xcolor)))))
(arguments
`(#:phases
(modify-phases %standard-phases